1. bradbamford's Avatar
    I hope someone has this figured out, because I've tried everything I know to get Straight Talk MMS to work using a T-Mobile sim.

    I have a 920 with straight talk AT&T sim and a 620 with straight talk T-Mobile sim.
    The 920 works flawlessly, the 620 not so much.

    According to the T-Mobile settings from Straight Talk, you only need two settings
    APN: wap.tracfone
    MMSC: http://mms.tracfone.com
    I've used these settings on my unlocked T-Mobile HTC ONE S (Android) and they work fine (so the SIM is fine).

    Is there anything else I might be missing?
    03-18-2013 10:16 AM
  2. windu's Avatar
    I have it working on an at&t sim.

    access point name att.mvno
    proxy address proxy.mvno.tracfone.com
    proxy port 80
    network type ipv4
    auth type none
    mms access point name att.mvno
    proxy address 66.209.11.33
    proxy port 80
    mmsc address http://mmsc.cingular.com
    network type ipv4
    auth type none
    03-18-2013 10:35 AM
  3. redeyss's Avatar
    Thanks for that windu, much appreciated!;-)
    03-18-2013 10:48 AM
  4. bradbamford's Avatar
    Okay, I got it working. Of course, stupid user error.
    I had to use "Access Point" under Settings to setup Data and MMS.

    So both Data and MMS are on the same screen, and I kept reading mms access point name as being a generic connection name that you could name whatever you wanted.
    Yes, stupid user error. You have to enter wap.tracfone here again.

    So that is all I entered.
    Don't use any Proxy or Ports for any settings (T-Mobile sims Only)
    [BOX=Straight Talk T-Mobile Data and MMS Settings]APN: wap.tracfone
    MMS APN:wap.tracfone
    MMSC:http://mms.tracfone.com[/BOX]
    will c1 and xandros9 like this.
    03-18-2013 11:40 AM
  5. will c1's Avatar
    I know this is an old post but just wanted to say thanks. I kept searching sites and trying different proxy and port settings but once I took your advice and just removed all the proxy stuff it now works.
    06-09-2013 10:16 PM
  6. bradbamford's Avatar
    Your welcome, glad I could help a fellow StraightTalk user.
    06-12-2013 11:17 PM
  7. Billy Taylor1's Avatar
    I have the H883G windows 8 phone from straight talk. Got it about 1 1/2 wks ago. Worked fine until this past weekend. I can send mms msgs, I can send a mms msg to myself and get the picture, but I can't receive any pic msgs from anyone else. Spent 2 1/2 hours on the phone with straight talk and they could not figure it out. I tried to put in these settings into my phone but couldn't get it going. Maybe I'm doing it wrong? Any advice?
    07-03-2013 11:39 AM
  8. bradbamford's Avatar
    I have the H883G windows 8 phone from straight talk. Got it about 1 1/2 wks ago.
    If you got straight talk only 2 weeks ago, then you probably have a T-Mobile straight talk SIM and these should work for you.
    You could have a bad registration in the straight talk system, I had that happen once when porting from straight talk T-Mobile to straight talk ATT (but that's rare)
    07-09-2013 12:39 AM
  9. Holly1022's Avatar
    i have a straight talk sim card in a htc one s tmobile phone and i have tried everything from the new apn settings....everytime i put in the settings for it and click the little green dot on the straight talk new apn it switches right back on its own to the tmobile apn and will not stay on the straight talk apn. and 2 it will not let me remove the tmobile apn cause they are locked and i cant figure out how to unlock them and delete that apn as well any ideas????? please help cause i really want my internet on my phone!!!!
    01-15-2014 01:41 AM

Similar Threads

  1. Straight Talk MMS not working...
    By xdaynax77 in forum Windows Central Archive
    Replies: 3
    Last Post: 12-13-2012, 07:21 PM
  2. Does anyone have a Windows Phone prop
    By JamzKroll in forum Gaming Discussion
    Replies: 2
    Last Post: 01-18-2012, 10:16 AM
  3. Does anyone have a Focus S with audio problems
    By pforlini in forum Windows Central Archive
    Replies: 40
    Last Post: 01-06-2012, 01:51 PM
  4. Does anyone have tethering solution?
    By EricCantona in forum Windows Central Archive
    Replies: 2
    Last Post: 12-03-2011, 05:18 PM
  5. Does anyone have email on server search working for gmail/gapps?
    By kalldrexx in forum Other Operating Systems
    Replies: 0
    Last Post: 09-29-2011, 11:37 AM
LINK TO POST COPIED TO CLIPBOARD