1. Sam Kennedy2's Avatar
    Whenever I take a video and play it back, it crashes a few seconds in, but the sound still plays in the background. The Phone doesn't crash, just the visual of the video.
    Also, whenever I take a picture, it takes 10+ seconds of looking at the photo taken to give me the option to take another. Even if I go out of the application and back onto it within that 10+ seconds, it still doesn't let me take another.
    Can anyone help me out? My Lumia 820 is fully updated, and I've tried resetting the camera settings.
    04-09-2013 01:13 PM
  2. HNNNNNGHHH's Avatar
    Have you tried restarting/rebooting the phone? That usually solved a few problems I had with my Lumia 920.
    04-09-2013 07:47 PM
  3. Marco Vigilante's Avatar
    do you have the mugen power battery 1800mah?
    I've the same problem, every time I try to take photo after pressing the "photo-button" my lumia 820 crash and shutdown.
    I think should be the battery but i'm not sure.....i'll ask to nokia care.
    04-13-2013 07:05 PM
  4. fkam's Avatar
    Guys,

    I have exactly the same problem. I think this is a software problem like a camera driver etc.
    After several tries and errors, I found the one thing. Please try and see if this works.
    Go to Photos -> settings -> Photos + camera -> Skydrive. Then disable automatic upload for both photos and videos.
    I believe automatic upload for photos is turned on by default.
    After I did this, I have not had the camera crash. I am hoping this can avoid the problem until Nokia or MS releases some patches.
    04-15-2013 04:28 PM
  5. syang87's Avatar
    Try changing the setting of storing pictures to the 'phone' (instead of SD card). Mine was crashing as well and I changed the setting and the camera no longer crashes.
    04-15-2013 05:30 PM

Similar Threads

  1. Weird camera crash on Lumia 820
    By Mattyh95 in forum Windows Phones
    Replies: 5
    Last Post: 03-13-2014, 05:52 AM
  2. Replies: 12
    Last Post: 02-25-2014, 06:27 AM
  3. Pictures taken with your Lumia 900 post em here
    By Dave Blake in forum Windows Central Archive
    Replies: 525
    Last Post: 12-28-2013, 07:30 PM
  4. Lumia 820 OS version after Portico Update
    By heredot90 in forum Windows Phones
    Replies: 21
    Last Post: 02-15-2013, 05:08 PM
  5. Replies: 17
    Last Post: 11-01-2012, 02:27 PM
LINK TO POST COPIED TO CLIPBOARD