Surface Duo is on salefor over 50% off!

  1. prasoon's Avatar
    Hi!

    I've have this problem since I the time I have brought Lumia 620. When I connect my lumia 620 to my PC (Windows ) the phone makes a connection sound and it shows up under My Computer as a portable device. but when I click on it, i am unable to view any files on it be in SD card or phone. I have tried removing the SD Card but then also it does not work.
    I have installed .Net 4.5 also but to no avail.
    Neither I have able to sync music etc with the WindowsPhone app.

    Can anyone help me? Thanks!!
    04-23-2013 02:00 AM
  2. claps's Avatar
    I had a similar issue after installing Lumia Storage Check Beta. I don't know if it is actually related but removing then re-installing it fixed the problem. Yes that's weird...

    edit : I hadn't checked for a few days and actually it's doing it again.
    And when it does work, it sometimes even shows another item called "Status" which I never noticed before:

    untitled.png
    Last edited by claps; 04-24-2013 at 01:13 AM.
    04-23-2013 10:13 PM
  3. prasoon's Avatar
    Mine is just blank. Cannot see the phone drive or the SD card :(

    Please someone help me...
    04-25-2013 04:39 AM
  4. SamsungPhoneUser's Avatar
    Thanks so much! I had unload and reloaded, then updated the drivers and nothing was working. When I read your post, I tried unlocking the screen and I was able to view my files again!
    04-08-2014 06:37 AM

Similar Threads

  1. Can't see files on Lumia 920 in Windows Explorer
    By Indefa in forum Windows Phones
    Replies: 23
    Last Post: 02-13-2018, 03:33 PM
  2. Data Roaming prompt when connecting to wifi
    By Br1anK in forum Other Operating Systems
    Replies: 0
    Last Post: 01-17-2013, 05:20 AM
  3. Nokia Music won't play when connected to wi-fi! ???
    By Beltelmel in forum Windows Phones
    Replies: 0
    Last Post: 12-30-2012, 04:26 PM
  4. Focus choppy when connected to computer
    By angry_jedi in forum Windows Central Archive
    Replies: 1
    Last Post: 05-11-2012, 11:29 PM
  5. Shows 4G when connected to my 3G microcell
    By RonV42 in forum Windows Central Archive
    Replies: 10
    Last Post: 04-09-2012, 12:15 PM
LINK TO POST COPIED TO CLIPBOARD