1. kylehimself's Avatar
    Hi good people of WPC!

    I've lurked around the forums and the site for a while but unfortunately my first contribution is due to a strange issue I've just come across.

    I've had a Lumia 620 since UK launch, so around 3 months. I decided I wanted to move up in the Lumia world and just today my 820 arrived. I got everything sorted with the new phone and when it was ready to go I powered off the 620.

    Around 20 minutes later I tried to boot it up again to check some old settings but it wouldn't turn on. So I inserted the charger and I'm now faced with a constant loop which goes like so...

    Phone vibrates.
    O2-UK splash screen displays.
    Low battery logo flashes on once.
    Nokia logo appears.
    Screen goes blank.
    Rinse and repeat.



    The strange thing is that prior to this the phone showed absolutely no signs of any problem. And just to note, when the phone was powered off the battery was about half full.

    Can anybody offer up any solutions? If so it would be much appreciated. Thankfully of all the days this could happen it was today when I got the new phone.
    04-23-2013 01:41 PM
  2. lnsertName's Avatar
    Try a soft reset, either holding the power button for 10 seconds, or power and Volume down.

    If this doesnt work, may be worth hard resetting.

    Hold the volume down, power button and camera button until the phone vibrates, then release the power button and keep the volume down and camera button down for another 5 seconds
    04-23-2013 01:59 PM
  3. kylehimself's Avatar
    Hard reset gave me the flashing red battery followed by a battery with a question mark over it. Now when I plug it in I get the O2 logo followed by the flashing red battery.

    Edit: It's now back in to a loop with the question mark. Vibrates, O2 screen, flashing read battery, question mark.
    Last edited by kylehimself; 04-23-2013 at 02:36 PM.
    04-23-2013 02:17 PM
  4. Victor Olivares's Avatar
    That happened to my lumia 620 a week ago and I was able to fix it, I hope this is the same problem.
    I turned off my phone, take the battery out and replaced my sim card, I placed battery again and booted up the device, everything went ok until I throw my phone to my bed and it turn off. I tried to turn it on but I couldn't, then I insert the charger, the phone was booting and I get the same loop (but without the question mark). I changed the sim again and the device booted, I thought it was something related to the sim.
    I went out home and at least 2 times I found the phone was turned off and once I took it from my pocket and I let it fall into my other hand and it gone to black.
    When I was back to home was thinking in all the process and I remembered that something odd happened when I removed the battery before the loop, when I lifted the battery I pulled it to the right and was a bit difficult to remove. I removed the battery, checked the battery connectors and I noticed the third pin's connectors were a little more separated than the rest.
    All I did to fix it was push the connectors together with a little wooden stick and now my phone works just like it did before.


    pin3.png
    04-23-2013 05:29 PM
  5. kylehimself's Avatar
    Yes! This worked. Thanks very much. I would never have even thought to have looked there. Of all the things it could be. The little pins - the very same one as circled in the photo - were nearly jammed all the way in.

    Thanks again, saved me a trip to the shop and a lot of hassle.
    04-23-2013 05:54 PM
  6. homieson89's Avatar
    Thank you so much. This worked.
    09-03-2013 04:13 PM

Similar Threads

  1. Setting up a load of Lumia 620's
    By jonno232 in forum Other Operating Systems
    Replies: 3
    Last Post: 04-10-2013, 12:48 PM
  2. Lumia 620 - $249 WP8 device
    By Gaichuke in forum General Phone Discussion
    Replies: 16
    Last Post: 12-07-2012, 07:02 AM
  3. Given Up of HTC & Nokia
    By zrob7 in forum Windows Phones
    Replies: 7
    Last Post: 11-25-2012, 11:12 AM
  4. okay I have given up on 3rd party podcast app...
    By fleeper99 in forum Other Operating Systems
    Replies: 7
    Last Post: 04-27-2012, 09:14 AM
  5. Nokia Lumia 800 Casing Close Ups
    By TheWeeBear in forum Windows Central Archive
    Replies: 1
    Last Post: 11-02-2011, 04:35 PM
LINK TO POST COPIED TO CLIPBOARD