1. SanjitVignesh's Avatar
    When scrolling, the device doesn't start scrolling immediately along with the finger. Instead, there is a very small lag, maybe half a second, before it starts following the finger. I previously had a Sony Ericsson Walkman W8 and had a similar experience with it. With the W8, I thought that it was a weak Android device and so it lagged. But now I am noticing it in my 620 too and almost all the devices I have seen.

    The only device where I haven't seen such a lag is in Apple devices.

    Is this because the device software takes some time to differentiate between a touch and a scroll? If yes, can this lag be reduced?
    Or is it a hardware issue?
    05-06-2013 10:14 AM
  2. WorzelGummage's Avatar
    I've noticed a similar thing on my 920 which first manifested after the Portico update. However, what happens on mine is that the screen will shift slightly down a fraction before it starts to scroll.
    05-06-2013 10:37 AM
  3. SanjitVignesh's Avatar
    So, this is only a software issue?
    05-06-2013 11:15 AM
  4. AccentAE86's Avatar
    I have no lag on my 920 and 810. But I do get it on my 620. Portico on all of them. It is a bit irritating, and surprising that it does that. Though my friend's 620's don't do it. Maybe it's just luck of the draw?
    05-06-2013 11:17 AM
  5. link68759's Avatar
    There is a slight lag on my 820 but no where near half a second. Maybe a quarter second. Nearly every touch screen I've ever used has noticeable lag, including the iPhones. The only exception is the LG Vu which had a touch screen fueled by magic. When I heard the 920 was going to have a high frequency display I thought maybe it would match the Vu's screen, but it doesn't :(

    In fact the 820 isn't supposed to have the higher refresh rate but I couldn't tell the difference between the 820 and 920 display speed, which is odd because I can see the difference with traditional monitors...

    Anyway if the lag is .5s then yeah that's odd. However there is some lag, but if you aren't looking for it you won't notice it.
    Sent from my RM-824_nam_att_101 using Board Express
    05-06-2013 11:22 AM
  6. constantinosmi's Avatar
    Check if the screen magnifier is on (easy of access settings). This will probably cause the screen to lag.
    WorzelGummage likes this.
    05-06-2013 11:31 AM
  7. SanjitVignesh's Avatar
    There is a slight lag on my 820 but no where near half a second. Maybe a quarter second. Nearly every touch screen I've ever used has noticeable lag, including the iPhones. The only exception is the LG Vu which had a touch screen fueled by magic. When I heard the 920 was going to have a high frequency display I thought maybe it would match the Vu's screen, but it doesn't :(

    In fact the 820 isn't supposed to have the higher refresh rate but I couldn't tell the difference between the 820 and 920 display speed, which is odd because I can see the difference with traditional monitors...

    Anyway if the lag is .5s then yeah that's odd. However there is some lag, but if you aren't looking for it you won't notice it.
    Sent from my RM-824_nam_att_101 using Board Express
    Ok, I exaggerated. It is a slight lag, but it is still there.

    Check if the screen magnifier is on (easy of access settings). This will probably cause the screen to lag.
    It is switched off.
    05-06-2013 11:36 AM
  8. WorzelGummage's Avatar
    Check if the screen magnifier is on (easy of access settings). This will probably cause the screen to lag.
    Well I never! That's fixed the problem I was experiencing. I didn't even know I had the magnifier turned on. Thanks very much, you're a star.
    constantinosmi likes this.
    05-06-2013 12:06 PM

Similar Threads

  1. Nokia Lumia 920 scrolling lag.
    By RushilPa in forum Windows Phones
    Replies: 22
    Last Post: 09-29-2015, 04:54 PM
  2. Lag on continuous touch scroll?
    By jcjackjay in forum Windows Phones
    Replies: 4
    Last Post: 06-25-2015, 03:19 AM
  3. Slight stutter or lag
    By DAIMONDY in forum Other Operating Systems
    Replies: 13
    Last Post: 06-01-2014, 05:59 PM
  4. Replies: 9
    Last Post: 04-08-2013, 11:01 PM
  5. Slight lag in the OS. Kill me now -.-
    By ammarmalik2011 in forum Other Operating Systems
    Replies: 16
    Last Post: 02-10-2013, 09:52 AM
LINK TO POST COPIED TO CLIPBOARD