1. Rauland's Avatar
    Hi, just another post on battery usage on the Nokia 820 which I believe could also apply to other lumias like the 920.

    Has anybody else experienced that while using wifi battery usage is very good but on data connection the battery drains within a few hours?.
    I realised that if I have it set to: 3G or 4G the battery, with hardly any phone use, can last for about 3 to 4 hours. (I have everything turned of: location service, brightness low, no apps allowed to run in the background, no apps left open etc...)

    What I noticed was while I have it set to either 3G or 4G the phone is constantly trying to connect to the best available network so its changing, non stop, between : H+, H, 3G which I believe is causing the battery to drain very quickly.

    If I set it to 2G it just stays on 2G and the battery seems to last much longer, not as long as with wifi but enough for me to get through the day.

    I'd like to know if anybody else is experiencing this, If this is normal or if it's a system error if it could be solved with some Nokia/windows phone update.

    Thanks
    Last edited by Rauland; 05-06-2013 at 02:26 PM.
    05-06-2013 02:08 PM
  2. ttsoldier's Avatar

    What I noticid was that while I have it set to either 3G or 4G the phone is constantly trying to connect to the best available network so its changing, not stop, between : H+, H, 3G which I believe is causing the battery to drain very quickly.

    Thanks
    You are correct and this is normal for any smart phone. Data kills battery. Even more so, as mentioned, when searching for a signal.

    Setting your phone to 2G when you have no use for high speed connection, is a major battery saver
    Laura Knotek and Rauland like this.
    05-06-2013 02:11 PM
  3. Rauland's Avatar
    Yes, but my workmate's Samsung is set to 3G and his battery lasts much longer.( I mean at least lasts the day.)

    I believe that windows phone may need some optimising with regard to how it manages phone signals. Maybe some future update could at least optimise it a little.

    On the other hand I believe that H is equivalent to 3.5G and H+ is 4G. If so, if I set it to 3G why does it try to connect to H shouldn`t it stick to 3G and below?
    05-06-2013 02:20 PM
  4. wmgreenjr's Avatar
    My battery seems to last pretty good on data via LTE. My battery app shows a higher rate of drain when on wifi vs LTE (edit: at least from what I remember). But when I leave the house, I turn off the wifi so it is not searching for available wifi - so not sure if that makes a big difference.
    05-06-2013 03:56 PM
  5. ttsoldier's Avatar
    Yes, but my workmate's Samsung is set to 3G and his battery lasts much longer.( I mean at least lasts the day.)

    I believe that windows phone may need some optimising with regard to how it manages phone signals. Maybe some future update could at least optimise it a little.

    On the other hand I believe that H is equivalent to 3.5G and H+ is 4G. If so, if I set it to 3G why does it try to connect to H shouldn`t it stick to 3G and below?
    does he even use his phone ? Lol
    05-06-2013 04:40 PM
  6. infinidim's Avatar
    I've got the exact opposite here. On Wifi my battery drains very quickly but on data it is reasonably good. This seemed to happen after I upgraded to version 1308 of the firmware.
    05-07-2013 07:29 AM
  7. Rauland's Avatar
    does he even use his phone ? Lol
    He doesn't make heavy use of it, just the occasional whatsapp check, email and thats about it. Even though it does last him a whole day on 3G. The difference with my nokia is that the battery would drain, even though I hardly used it, within a few hours, 4 at most only on 3G. I believe that windows/nokia should be aware of this and hopefully in future updates we could see some improvement. (For instance on idle it could drop down to 2G instead of staying searching for other signals...... I guess that would optimise it a little... or If I select 3G it shouldn't connect to 3.5G (H)..... )

    Today I had it all day on 2G used it quite a lot and after about 12 hours use I still have 20% left (browsing, saw a few videos, played some games, used whatsapp,evernote,skydrive....) which to me is excelent as It allows me to make full use of the phone without worrying about the battery....

    Overall I'm loving the phone the operating system is awesome and the apps are amazing...
    Last edited by Rauland; 05-10-2013 at 10:51 AM.
    05-07-2013 02:05 PM
  8. infinidim's Avatar
    Here is an update on my findings so far. As I posted before I have been doing a lot of work at looking at battery drain and here is what I have found so far. If you don't have data or Wifi switched on then the battery does last quite well. If you switch just data (3G in my case currently) on then it does start to drain the battery a reasonable amount. If you only switch Wifi (I have an "N" mode router) on then it seems to drain it dramatically - I have seen drain as bad as 7% in 20 minutes without using any communications apps.
    Rauland likes this.
    05-10-2013 04:52 AM
  9. Jozz's Avatar
    I have got a Nokia Lumia 820 since a couple of days and experienced an extreme battery drain on 3G. I switched to 2G and now battery life is excellent. I still get my WhatsApp messages. I only check my email manually, because at work, I'm behind a computer and can see new emails when they arrive in Google Talk.

    I installed Battery Level for WP8 and now at 100% (just charged) it says 3 days, 13:12 hours remaining.
    Rauland likes this.
    05-17-2013 12:47 PM

Similar Threads

  1. Problems with data connection after Mango Update . ( LG E900)
    By coolzd123 in forum Windows Central Archive
    Replies: 12
    Last Post: 05-23-2012, 03:32 AM
  2. Data connection problems with carrier
    By LivinginaBox in forum Windows Central Archive
    Replies: 4
    Last Post: 10-18-2011, 05:38 PM
  3. Data Connection (and other) Issues with Quantum
    By zr2s10 in forum Windows Central Archive
    Replies: 4
    Last Post: 09-30-2011, 01:33 AM
  4. Issues with data connection
    By Redbird1 in forum Windows Central Archive
    Replies: 6
    Last Post: 11-22-2010, 05:35 PM
LINK TO POST COPIED TO CLIPBOARD