1. borasar's Avatar
    Hi,

    I believe at this point a lot of people are experiencing or are aware of NL920 issues after the 1308 firmware update. We currently have a number of threads on these boards about the 1308 issues divided by regions or providers. This thread is an attempt to aggregate all the issues in variety and volume into one thread, to really make the extent and the size of the issues visible to Nokia. This way we might speed up the process and get the fix for the 1308 (aka 1314) that AT&T customers got already.

    So please, if you are experiencing issues as a result of 1308 firmware or are aware of any issues post them here, regardless of region. Also please try to stay on topic as this will be the only way the thread will get stickied.


    I have been in touch with Nokia Care and have been told that 1308 that was pushed to me was incomplete and will require another firmware update (1314) to repair the current network/connectivity issues. Nokia is working on it, but have no timelines available at the moment, which is odd considering AT&T customers got 1314 (which I believe still doesn't address all the issues) a while back.

    Personally I have had extensive connection issues, where my phone is very rarely displaying LTE, typically I'm seeing 3G (1 or 2 bars), E, or no connection. Often times this happens on its own without me moving the phone. As a result, there are missed/dropped calls, SMS not coming through both ways, MMS has been completely rendered useless. When I do get LTE and do a speedtest, I'm experiencing speeds at around 5mbps on the up and down and sometimes as low as 0.5mpbs on the up, which is obviously way off the LTE speeds.
    Lundon44 likes this.
    05-12-2013 01:17 PM
  2. Lundon44's Avatar
    Yes there's clearly a problem with the latest Nokia firmware update for the Lumia 920 on Rogers similar to what AT&T experienced with theirs. Issues experienced since the update as follows.

    - dropped calls and sms failing
    - frequent intermittent no signal connectivity
    - random data signal drops from LTE to edge or below
    - some live tiles not updating and toast notifications not being received
    - partial static from speakers while phone is set to silent
    - call forwarding and call waiting options are greyed out with LTE selected as the highest data connection
    - Internet Sharing no longer works or can be turned on


    A fix for this asap would be great. Some people actually use their phone as a work phone or home phone replacement and the amount of calls I miss on a regular basis has definitely become a large burden to my life. Each day with this problem pushes me closer and closer to getting rid of my phone.
    borasar likes this.
    05-12-2013 01:33 PM
  3. cellneuron's Avatar
    Are you sure those have anything to do with 1308 updating? My lumia 920 has all those problems before updating.

    Yes there's clearly a problem with the latest Nokia firmware update for the Lumia 920 on Rogers similar to what AT&T experienced with theirs. Issues experienced since the update as follows.

    - dropped calls and sms failing
    - frequent intermittent no signal connectivity
    - random data signal drops from LTE to edge or below
    - some live tiles not updating and toast notifications not being received
    - partial static from speakers while phone is set to silent
    - call forwarding and call waiting options are greyed out with LTE selected as the highest data connection
    - Internet Sharing no longer works or can be turned on


    A fix for this asap would be great. Some people actually use their phone as a work phone or home phone replacement and the amount of calls I miss on a regular basis has definitely become a large burden to my life. Each day with this problem pushes me closer and closer to getting rid of my phone.
    05-12-2013 02:03 PM
  4. borasar's Avatar
    I've only started experiencing similar issues after updating to 1308

    what is your firmware version?
    Are you sure those have anything to do with 1308 updating? My lumia 920 has all those problems before updating.
    05-12-2013 02:08 PM
  5. Jon Farley's Avatar
    THIS NEEDS TO GET SORTED NOKIA!!!!! ive read countless posts all over the internet about people having this problem, for a company who were relying on this handset to get them out of trouble nokia are really not making a very good job of it. I for one cant speak for the phone before the update seeing as i recieved mine in feb with the upgrade already on it. what i can say is that this problem is really starting to become a hinderance. ive just lost 2 months worth of work because the customer couldnt get through to me. on top of countless instances where my calls, important or not are being dropped. As has already been mentioned this is not just in the UK but worldwide. simply not good enough. I love this phone. it is a great device but at the moment its just not a phone.
    05-13-2013 09:59 AM
  6. hegalong's Avatar
    Im located here in Belgium and I bought this unit unlocked from Germany.

    Guys (besides the blurry image), did you ever tried to use the ISO and the exposure settings? I expect a brighter image at higher ISO and higher exposure but Im not satisfied with the results after the update :(. Please check if you have the same experience as mine. Thanks.

    Default setup


    Set to Night mode and others set to default


    While in Night mode, Exposure set to 2 and ISO set to 800
    05-13-2013 06:53 PM
  7. Sam Wong's Avatar
    Hong Kong user. LTE connection keeps dropping to no signal after 1308 update.
    05-14-2013 09:53 AM
  8. Aldrin Divera's Avatar
    Singapore user....After 1308 update, signal keeps on dropping to no signal and will take awhile for signal to comeback again.
    05-18-2013 12:11 PM
  9. nikhilr51's Avatar
    Just adding my 2c, I flashed 1308 to my australian 920 (1308 was pulled by nokia before it was released here).
    I used it for quite some time, never had any problems. Flashed to 1314 as well and i feel like its the same as 1308.

    However Australians have never officially got either 1308 or 1314, we're still on portico.
    Last edited by nikhilr51; 05-19-2013 at 08:27 AM.
    05-19-2013 07:52 AM

Similar Threads

  1. unlocked 920 (not udated to 1308) connectivity issue
    By hyperthermia in forum Windows Phones
    Replies: 3
    Last Post: 05-14-2013, 10:54 AM
  2. Post 1308 update problems - Non AT&T users
    By rakesh1982 in forum Windows Phones
    Replies: 9
    Last Post: 05-04-2013, 11:52 PM
  3. Post your issues on Nokia's support forum - link
    By theefman in forum Windows Central Archive
    Replies: 1
    Last Post: 04-29-2012, 11:10 PM
  4. Any non-call related issues on the titan?
    By E_man#CB in forum Windows Central Archive
    Replies: 11
    Last Post: 01-06-2012, 09:55 PM
  5. Post Mango Update Issue & Question
    By jasqid in forum Other Operating Systems
    Replies: 3
    Last Post: 09-27-2011, 09:31 PM
LINK TO POST COPIED TO CLIPBOARD