1. homieson89's Avatar
    Ok. I'm confused with all the posts about the L920 on T-Mobile. I have the $50 unlimited plan, and I'm getting 2g/edge and switches to 4g at times and goes back to edge.

    First... What are the APN and MMS settings for T-Mobile? Maybe I added an extra digit or something.
    Second... Access point, what is it and how do I use it..
    Third... How do I get 3g?

    Thanks
    06-15-2013 11:35 PM
  2. Benjamin Mendez1's Avatar
    Theirs already forums on these topics.
    06-16-2013 01:38 PM
  3. doublesman3486's Avatar
    Ok. I'm confused with all the posts about the L920 on T-Mobile. I have the $50 unlimited plan, and I'm getting 2g/edge and switches to 4g at times and goes back to edge.

    First... What are the APN and MMS settings for T-Mobile? Maybe I added an extra digit or something.
    Second... Access point, what is it and how do I use it..
    Third... How do I get 3g?

    Thanks
    Connection Name : T-mobile mms

    Internet APN

    Access point name : epc.tmobile.com
    Username : Blank
    Password : Blank
    Proxy Address : 216.155.165.50
    Proxy Port : 8080
    Network Type : IPv4
    Authentication Type : none


    MMS APN

    MMS access point name : epc.tmobile.com
    Username : blank
    Password : blank
    Proxy Address : 216.155.165.50
    Proxy port : 8080
    MMSC address : http://mms.msg.eng.t-mobile.com/mms/wapenc
    Network type : IPv4
    Authentication type : none

    important : after tapping it to make it active, restart your phone. :)
    homieson89, ismeyall and jfa1 like this.
    06-16-2013 02:27 PM
  4. Musicman247's Avatar
    For the internet APN just use fast.t-mobile.com that will enable everything plus LTE when available.
    jbjtkbw007, homieson89 and jfa1 like this.
    06-16-2013 02:34 PM
  5. homieson89's Avatar
    Thank you both
    06-17-2013 12:42 AM
  6. AbsoluteZerow's Avatar
    Or if you want everything to work (LTE, 4G/HSPA+, AND Group Messaging), install the Nokia Access Point app and select T-Mobile in the listing. I had to do this for Group Messaging to work properly. But, I also have a unlocked pentaband 920, which may differ from what you have.
    06-17-2013 11:13 AM
  7. rush_ad's Avatar
    Or if you want everything to work (LTE, 4G/HSPA+, AND Group Messaging), install the Nokia Access Point app and select T-Mobile in the listing. I had to do this for Group Messaging to work properly. But, I also have a unlocked pentaband 920, which may differ from what you have.
    I have AT&T unlocked 920 that I use on T-Mobile US. There is no need to install Access Point app on latest firmware update.
    You can use the Internet and MMS APN settings available under Settings --> Cellular

    I use group MMS and internet just fine. I am getting LTE today in St. Pete FL.
    06-17-2013 02:48 PM
  8. AbsoluteZerow's Avatar
    You don't have a pentaband 920, so my post is still valid to pentaband owners.
    06-17-2013 03:32 PM
  9. doublesman3486's Avatar
    You don't have a pentaband 920, so my post is still valid to pentaband owners.
    Is the rogers 920 pentaband?

    RM-821 is also pentaband which is the international unlocked 920
    06-17-2013 07:13 PM
  10. waterfallofdestiny's Avatar
    Is the rogers 920 pentaband?
    Yes. The Rogers Lumia 920 includes the 1700/2100 MHz bands.
    06-18-2013 08:21 AM
  11. phanboy4's Avatar
    Anybody that pays for T-Mobile hotspot functionality tried that with LTE?

    I'm thinking my area got refarmed because as of today I'm seeing an LTE symbol now where I used to see 4G. This is on a BUILD 920 with Rogers firmware. Sharing complains that I "don't have a cellular connection", which is a different error than what the keyboard hack solves.

    Using/removing various manual APN/MMS settings doesn't seem to affect it.
    06-18-2013 10:35 AM
  12. ismeyall's Avatar
    I tried this & it works.. The only problem is that I cannot get my mms to work. I can't view or send pic when I activate "T-mobile mms". Any help?
    Thanks again!
    06-18-2013 11:15 AM
  13. phanboy4's Avatar
    Hmm, nevermind, seems to work now. Could very well have been a temporary refarming quirk.
    06-18-2013 04:49 PM

Similar Threads

  1. Lumia 920 on T-mobile?
    By Nogitsune Micah in forum Windows Phones
    Replies: 67
    Last Post: 03-11-2014, 09:41 AM
  2. Replies: 2
    Last Post: 12-01-2013, 11:03 PM
  3. I'm seeing LTE on my Lumia 920 with T-Mobile in SF
    By eshy in forum Carrier Discussion Lounge
    Replies: 2
    Last Post: 04-01-2013, 08:51 PM
  4. Lumia 920 on T-Mobile USA now?
    By Dean Macke in forum Windows Phones
    Replies: 6
    Last Post: 03-27-2013, 09:02 AM
  5. For Those With a Lumia 920 On T-Mobile USA.
    By Dinky89484 in forum Windows Phones
    Replies: 2
    Last Post: 12-24-2012, 10:59 PM
LINK TO POST COPIED TO CLIPBOARD