1. rafuru's Avatar
    Hi!

    I recently bought my Lumia 720 and since a couple days I have a big problem. Something in my phone is draining the battery, 'cause I charge to 100% and after 2 hours My battery has <70%, plus I feel kinda heat on the top (where the speaker is placed).

    I have made some tests uninstalling Line, Facebook, turning off the wi-fi or H+ but the problem persists. Yesterday I restore my phone from the configuration menu and the problem persists...

    Can you help me? or I need to claim my guarantee ?
    07-17-2013 10:40 PM
  2. OzRob's Avatar
    Hi!

    I recently bought my Lumia 720 and since a couple days I have a big problem. Something in my phone is draining the battery, 'cause I charge to 100% and after 2 hours My battery has <70%, plus I feel kinda heat on the top (where the speaker is placed).

    I have made some tests uninstalling Line, Facebook, turning off the wi-fi or H+ but the problem persists. Yesterday I restore my phone from the configuration menu and the problem persists...
    Just to clarify, you say you "restored" your phone. By this I assume you mean you did a full factory reset that wiped all your downloaded apps and data and then you set up your phone from scratch again. Even after doing this you are still getting excessive battery drain. Is this correct?
    07-17-2013 10:47 PM
  3. rafuru's Avatar
    Yup, I just installed Facebook, Line and Twitter
    07-17-2013 11:03 PM
  4. vidhunprakashmk's Avatar
    I had somewhat ok performance with the 720 battery but seeing its amazing battery life reviews yesterday i factory resetted my phone. And i must say the battery life after that is amazing indeed.. Hours of calling, data with youtube streaming for a day, my battery has enough juice for one more day :)
    07-17-2013 11:26 PM
  5. Mayur M Naravani's Avatar
    I have Nokia Lumia 720 too, As i have noticed the problem as the battery wont drain much on wifi, but when I keep my data connection on for few minutes suddenly the percentage decreases by 10%.
    07-18-2013 09:59 PM
  6. SoftVision's Avatar
    The only issue I've had with the battery was when HERE Drive was running in the background. Check and see if it is disabled in Settings -> Applications -> Background Tasks.
    07-18-2013 11:03 PM
  7. OzRob's Avatar
    Yup, I just installed Facebook, Line and Twitter
    I would uninstall Facebook and see if things are better. There have been reports of this app draining battery.

    As the post above says, check Settings -> Applications -> Background Tasks and disable anything you don't really need.
    07-19-2013 12:17 AM
  8. OzRob's Avatar
    I have Nokia Lumia 720 too, As i have noticed the problem as the battery wont drain much on wifi, but when I keep my data connection on for few minutes suddenly the percentage decreases by 10%.
    It sounds like you may be in a poor area for 3G reception. The lower the signal strength the harder the radio needs to work to maintain a connection. If this is the case, there is really nothing you can do about it except change to a carrier that has better coverage in your area.

    Having said that, 10% drop in just a few minutes is not normal, even with low signal strength. I suspect you have other things going on as well.
    07-19-2013 12:19 AM
  9. Rodrigo Mendes's Avatar
    The only issue I've had with the battery was when HERE Drive was running in the background. Check and see if it is disabled in Settings -> Applications -> Background Tasks.
    This is the most common cause of battery drain. In Background tasks, I recommend to disable everything.

    On standby, Lumia spends just a little of battery.
    07-19-2013 07:07 AM

Similar Threads

  1. lumia 520 hanging problem
    By Sumit Raju in forum Windows Phones
    Replies: 21
    Last Post: 05-17-2015, 10:19 PM
  2. Does anyone still experience battery drain issues?
    By pantsaregood in forum Windows Phones
    Replies: 11
    Last Post: 07-18-2013, 01:59 PM
  3. 925 Accessories Thread
    By Paedin in forum Windows Phones
    Replies: 5
    Last Post: 07-17-2013, 03:18 PM
  4. Anyone having a problem sending a text?
    By chefster74 in forum Windows Phones
    Replies: 4
    Last Post: 07-17-2013, 02:19 PM
LINK TO POST COPIED TO CLIPBOARD