1. mmarksx19's Avatar
    Hi all,

    I forgot to put my phone on charge last night, woke up and now my battery is flat.
    I plugged it into the mains charger and all the phone is doing is showing the Nokia logo, vibrating then showing a picture of a battery with a red bar in it. This is constantly cycling through every few seconds. The vibration is driving me mad (it is on my desk next to me) and I really want to use the phone!

    What do I do??????
    08-29-2013 02:43 AM
  2. Mike_J's Avatar
    Just give it an hour to charge - it should sort itself out. Seems when battery in lumia's is super flat it requires a certain amount of charge before it will allow the phone to turn on. A corded charger will be quicker than wireless
    08-29-2013 03:03 AM
  3. harshythsunkari's Avatar
    It just needs a boost . Take it to the service centre.Hardly takes 5 mins to resolve the issue . Faced the same problem with my 520
    08-29-2013 03:25 AM
  4. andrewkeith5's Avatar
    All that means is that the phone doesn't have enough power in it to switch on (it requires a certain level to start all the components up).

    It can take up to 30 minutes to an hour to accumulate enough charge, at which point the phone will automatically turn itself on and boot up as normal.

    However, the fact it's doing it repeatedly suggests either something's wrong or it's seriously down on power so if it does it for more than an hour or so come back... Also don't forget to let it charge fully once it does turn on as it'll only be on absolute minimum power (I think it requires ~4-5%)
    08-29-2013 03:32 AM
  5. mmarksx19's Avatar
    Thanks all,

    Left it about 90 minutes and it powered on. All seems to be fine except it lost the time and date for some reason. Set that up and everything else is OK. Thanks all for the help.

    Michael
    08-29-2013 04:45 AM
  6. andrewkeith5's Avatar
    Thanks all,

    Left it about 90 minutes and it powered on. All seems to be fine except it lost the time and date for some reason. Set that up and everything else is OK. Thanks all for the help.

    Michael
    Glad all is good :) Yeah it did seem like it was very low! The time is odd to lose on a battery discharge, maybe it really didn't have anything left! Normally the only time mine loses the time is after a soft reset...
    08-29-2013 05:36 AM
  7. Rohin Sethi's Avatar
    I bought a 2Amp Wall charger and it really helps quickly charge the battery in such situations. The regular wall chargers are around 700mA and take longer to charge the battery enough to restart the device.
    08-29-2013 05:16 PM

Similar Threads

  1. New Windows Phone User
    By cwatkinz in forum New to the Forums? Introduce Yourself Here!
    Replies: 10
    Last Post: 08-29-2013, 03:53 PM
  2. $19 Registration fee for windows phone dev center
    By brmbjn in forum Other Operating Systems
    Replies: 1
    Last Post: 08-29-2013, 01:40 AM
  3. Battery and Background Apps
    By manilabeans in forum Other Operating Systems
    Replies: 2
    Last Post: 08-28-2013, 11:11 PM
  4. Control a Powerpoint presentation running on RT from a phone...
    By Greg Roberts2 in forum Other Operating Systems
    Replies: 1
    Last Post: 08-28-2013, 09:11 PM
  5. Replies: 1
    Last Post: 08-28-2013, 08:25 PM
LINK TO POST COPIED TO CLIPBOARD