1. Mona Tamimi's Avatar
    Hello everybody, this is the second time it happened to me. First time was 2 weeks ago and the fix was easy, just did a phone call with the earpiece on and switch voice to loudspeakers and viola! Now it happened again, and this time it's clear that it's a hardware issue. So here's what I tried to do:

    -Connected third-party earpieces and then disconnected them repeatedly with different ones, nothing
    -Tried the phone call trick, nothing
    -Insert a small paper in form of a cylinder in the 3.5mm jack for a few mins (Got the idea off some googling), nothing
    -Soft/Hard reset, nothing
    -Heck I've even re-flashed with NCS, nothing

    I know that the phone is stuck in earpiece mode because the Dolby Digital audio settings and Equalizer and Radio are all available, but there's no sound coming from the speakers whenever I play music or videos, I can't even hear or be heard in a phone call if I don't enable loudspeakers.

    Also I can't have my phone replaced because my warranty is from another country which I don't live in ATM, and it isn't valid here in Romania. Heck there aren't even any Care Centers here, so my only bet is to go to a third-party store to try to fix it. I've even found an earpiece audio jack on eBay for like 7$, but delivery time is between 10-30 days and that's a lot!

    Any suggestions?? I've had this phone for 7 months and everything is perfect with it and I haven't dropped it or misused it in any way, nor it had contact with water.
    09-07-2013 03:42 PM
  2. pankaj981's Avatar
    Insert any headphone and try to rotate the jack rigorously, its mostly the headphone contact that stuck, rotating the headphone jack continuously might solve it
    09-07-2013 03:58 PM
  3. Nemanja Pavlovic's Avatar
    I had the same issue after using some old headphones with a possibly damaged jack. For me, the fix was easy. Just plugged in and out the Nokia earpieces, worked fine ever since...
    09-07-2013 04:27 PM
  4. Mona Tamimi's Avatar
    Insert any headphone and try to rotate the jack rigorously, its mostly the headphone contact that stuck, rotating the headphone jack continuously might solve it
    I'v'e just done that for half an hour but still nothing... I'm even worried I might damage it more like that.

    I had the same issue after using some old headphones with a possibly damaged jack. For me, the fix was easy. Just plugged in and out the Nokia earpieces, worked fine ever since...
    Not so lucky as you I guess :/ I've already used Nokia earpieces.
    09-07-2013 05:51 PM
  5. pankaj981's Avatar
    Ok in that case I am out of ideas, hope you get it resolved somehow.
    09-07-2013 06:10 PM
  6. metalchick719's Avatar
    You might have a defective phone. I would contact Nokia Care if I were you.
    09-07-2013 10:14 PM
  7. jamie johnston's Avatar
    I had the same problem, i plugged in an external speaker to test something. late in the day i noticed i had no sound unless i used head phones. i managed to get it working again by poking a WD40 red spray tube (clean, of course) and got it to work. it was still intermittent so instead of going through the hassle of taking it back to the shop in France i bought it from (i live in Belgium) i decided to buy a new headphone jack and replace it myself. it took literally 5 mins to do and now it works fine. i was going to buy a little dust cap for it to keep anything out of it in the future and to not risk the same thing happening again. stellatech in germany stock all sorts of parts for the lumia 920.
    09-08-2013 07:44 AM
  8. hyperthermia's Avatar
    i also have this issue, my phone lost sound and vibration. even when i connect headset , no sound still. this is frustrating. it happened after i did a call and put it to loudspeaker. this was 2 days after amber. i hope someone can help. i also did soft and hard reset, no helo
    09-10-2013 11:18 PM
  9. Lumis90's Avatar
    I had this problem with L800 so I had to change the whole case of the phone, because of headphones jack the earpeace broke
    09-13-2013 09:35 AM
  10. tomcrook's Avatar
    I had this happen to my HTC One X and made it worse ... whatever you do DONT use a screwdriver

    Dont insert screwdriver into headphone socket. | HTC One X > XDA (i'm the OP in this thread)
    09-13-2013 11:54 AM

Similar Threads

  1. Ringtone Volume, can I Lock it??
    By arislgr in forum Windows Phones
    Replies: 9
    Last Post: 04-19-2014, 05:20 PM
  2. My speaker randomly stopped working ( Help!!! )
    By Berkay Kaya in forum Windows Central Archive
    Replies: 6
    Last Post: 12-09-2013, 12:20 PM
  3. I LOVE my Nokia Lumia 520.
    By Matite in forum Other Operating Systems
    Replies: 17
    Last Post: 10-19-2013, 08:49 PM
  4. Photos Tile, it could be so much better so easy
    By Boris Lozac in forum Other Operating Systems
    Replies: 6
    Last Post: 09-14-2013, 01:28 PM
  5. trading my l1020 but how do i wipe my information off the phone?
    By PappesHartley in forum Windows Phones
    Replies: 2
    Last Post: 09-07-2013, 02:03 PM
LINK TO POST COPIED TO CLIPBOARD