1. Gazlar22's Avatar
    I just got a 'new' replacement phone back from Nokia after returning my previous handset three times to try to fix the case creaking issue. The eventual outcome was that - after replacing the motherboard, flashing the software and on the third attempt, doing nothing - the engineers couldn't find the fault and sent me a replacement phone.

    I was chuffed when I opened the package to find what appeared to be a shiny new lumia, no scratches or creaks and all seals present. All seemed well, I hooked it up to my PC to redownload my apps from the Windows Phone site, then the latest update popped up so I installed that. When it came to charging the phone later, I plugged it into the mains to find it wouldn't charge. I tried 3 different chargers and mains sockets before resetting the software, which did nothing but cause the battery icon to constantly be present on the phone for some reason.

    The phone will charge, however, if I plug it into my computer when it's fully logged in. It won't charge on other computers. I tried leaving the phone hooked to the mains whilst soft and factory resetting.

    What the hell is going on? I've had it with these phones. Do I return it a fourth time and go another week without a handset, or is this somehow a software issue that might be fixable?
    09-21-2013 05:50 AM
  2. Villain's Avatar
    simplify your issue? LOL could just be me getting off a 12hr shift but I don't fully understand your issue.
    09-21-2013 06:10 AM
  3. Gazlar22's Avatar
    Haha, essentially the phone will only charge from my computer. No mains chargers or other computers will charge it
    09-21-2013 06:12 AM
  4. Villain's Avatar
    Was going to suggest disabling the sleep mode setting on the computer **** yeah that's odd it won't charge from regular wall chargers. Different USB chargers and the plug nub?
    09-21-2013 09:25 AM
  5. Gazlar22's Avatar
    Does anyone know the best way for me to roll back to the previous software version? I've got a feeling the update may have messed the phone because I left it plugged into my PC the entire time

    EDIT - Yeah I've tried different plugs, different USB cables, everything. It has to be a software issue or else it wouldn't charge at all
    09-21-2013 09:32 AM
  6. Villain's Avatar
    why did you plug it in to update?


    I would do a factor reset and test without reinstalling a backup
    09-22-2013 06:32 AM
  7. Yiannis Mansolas's Avatar
    I've had problems charging and connecting to a computer both with an Ativ S and a Lumia 920. To cut a long story short, the charging problems were due to a trusted but apparently faulty charger.
    The PC connection issues were solved when I connected the phones to the computer after rebooting both (phone and computer). It was probably a driver installation issue because after that initial setup I don't have to reboot the phone or the computer anymore to connect them.
    09-22-2013 09:52 AM
  8. Gazlar22's Avatar
    I plugged in to reinstall my apps easily from the windows phone site. The update just happened to pop up whilst my phone was plugged in. As I said, I've now tried a number of chargers: one which came with the 920, one which came with a 520 and one which came with an 800, as well as a ZTE micro usb charger. None of these work.

    However, to make things a little weirder, I plugged the phone in at a friend's house with his 925 charger and it started charging. I guess the next step will be to try his charger at my house, but I'm not gonna be able to do that for a while.

    I've never known a phone to be this temperamental with charging. It consistently works from PCs but won't work from any mains socket with any charger in this house.
    09-22-2013 10:25 AM
  9. acousticpoem's Avatar
    My Nokia charging stand or wireless plate wont work in my office at work. Yet the USB does and they work no problem at home. Electrician said it would a slight fault with the constancy of the electrical supply at the office. It may affect you too.
    09-22-2013 10:34 AM
  10. Gazlar22's Avatar
    Yeah sounds like that could be the case, but there's a 520 in the house that charges fine and my previous 920 was fine as well. May be another hardware issue after all -_-
    09-22-2013 10:48 AM
  11. jojapath's Avatar
    Try to change the fuses of your house.
    09-22-2013 09:20 PM

Similar Threads

  1. 820 "other storage" issue
    By Optimize in forum Windows Phones
    Replies: 30
    Last Post: 09-12-2015, 05:20 PM
  2. Music player issues - Smart DJ Mix, Album art and compilations
    By carlosedp in forum Other Operating Systems
    Replies: 7
    Last Post: 10-17-2013, 02:34 PM
  3. Nokia 720 Glance Issue
    By Pulserider in forum Windows Phones
    Replies: 8
    Last Post: 09-21-2013, 08:30 AM
  4. Known/Unknown issue with PC to phone.
    By Microsoftjunkie in forum Other Operating Systems
    Replies: 1
    Last Post: 09-20-2013, 10:49 PM
  5. Pro Shot issues
    By lewiedude in forum General Phone Discussion
    Replies: 1
    Last Post: 09-20-2013, 10:41 AM
LINK TO POST COPIED TO CLIPBOARD