1. DeZerT's Avatar
    So I got my Ativ S today from Amazon, the phone is brand new. However after I was done configuring it I tried to download an app and the downloads seem to take ages. After a while they just stop, not even halfway, and some "connection issue" message pops up. However I can browse without issues so the connection is fine. What should I do? I haven't been able to install a single app so far.
    09-30-2013 08:58 AM
  2. stephenjxn's Avatar
    Try rebooting the phone. After you have configured the phone, you should always do a "hard reboot".
    DeZerT likes this.
    09-30-2013 09:08 AM
  3. DeZerT's Avatar
    Thx for the reply. Unfortunately I tried already. I even restored the phone to factory defaults, even without the sd card, but still after configuring everything no luck...
    09-30-2013 09:15 AM
  4. mary beth hale's Avatar
    i always download apps/updates while on wifi.
    09-30-2013 09:34 AM
  5. DeZerT's Avatar
    Just a small update...finally I managed to get this to work, probably it was just my router acting funny, such a waste of time lol...anyway I'm glad it's all solved now, thanks for the support guys.
    10-01-2013 01:27 PM

Similar Threads

  1. [APP] urgentHelp an App that can save your Life and your loved
    By Alexander Krenn in forum App Spotlight
    Replies: 4
    Last Post: 10-03-2013, 08:28 AM
  2. Hello from an Android/Nexus user migrating to a 1020!
    By sjgore in forum New to the Forums? Introduce Yourself Here!
    Replies: 10
    Last Post: 10-01-2013, 08:40 AM
  3. Want my Yahoo calendar on WP8 phone but Outlook.com won't sync
    By squid729 in forum Other Operating Systems
    Replies: 6
    Last Post: 09-30-2013, 09:55 PM
  4. Replies: 3
    Last Post: 09-30-2013, 04:10 PM
  5. App for Gym goers
    By gaol-anseo in forum App Spotlight
    Replies: 1
    Last Post: 09-30-2013, 08:49 AM