1. elsebas's Avatar
    Hi!

    I've seen a couple of similar posts but found no answer to my question so please let me tell you my story:

    I bought a brand new unlocked and unbranded Nokia Lumia 920 (got it from the UK to be used in Ireland). I ordered a micro SIM from Tesco Mobile and when I inserted I got the message "SIM card missing or invalid", I thought that this may be due to the card not being active yet but when I put the card on a different phone first I was requested to enter the PIN and then I was advised that the card wasn't active, in the 920 it was just "SIM card missing or invalid".

    I activated the SIM and transferred my number, put it on the 920 and again "SIM card missing or invalid", back to the old Nokia and working. So it had to be the phone but it was new so I ordered Micro SIMs from every possible company, until now LycaMobile and 48 have not worked but Meteor has, I've tried at least two SIMs of every company that failed to work the first time. Some of them were active, some not, some of them were empty some already had a number, as said only 48 worked and works from day 1.

    I noticed that the chip on the SIM was a different size, I mean, all SIMs are micro SIMs the same size, but the Meteor one has a smaller chip (the copper part where the info is stored), I checked all the other SIMs that I had in the house and some of the older SIMs had smaller and some larger chips but until today I had been able to swap them all in my old phones with no problem.

    I started looking for information online and tried the hard reset, it didn't work, I read then that I should use the card for a while in a different phone so that the SIM was perfectly connected to the network, I did so with one of the Tesco Mobiles SIM but when I tried it in the 920 "SIM card missing or invalid", I am thinking now of updating the software but I don't know if this will solve anything.

    Any ideas? Anybody experienced the same issue and was able to find a solution?

    Thanks in advance!!

    Sebas
    10-03-2013 08:57 AM
  2. pankaj981's Avatar
    Get it replaced using the warranty, seems to me as a hardware problem.
    10-03-2013 12:37 PM

Similar Threads

  1. Facebook account syncing in people app on Wp8 and W8
    By WoWNyx in forum General Phone Discussion
    Replies: 18
    Last Post: 11-17-2013, 06:45 AM
  2. Lock photos and videos in windows phone 8
    By Jonathan ladd in forum App Spotlight
    Replies: 1
    Last Post: 10-03-2013, 08:54 PM
  3. regarsing security in windows phone
    By nitesh27 in forum Windows Phones
    Replies: 3
    Last Post: 10-03-2013, 04:20 PM
  4. HD Voice on Lumia 920
    By greycounciller in forum Windows Phones
    Replies: 0
    Last Post: 10-03-2013, 05:51 AM
  5. Lumia 925 rm910 - Not LTE?
    By retro_to_biggy58 in forum Windows Phones
    Replies: 1
    Last Post: 10-03-2013, 04:04 AM
LINK TO POST COPIED TO CLIPBOARD