Dell Technologies Cyber Savings Event - Up to 45% off

  1. Technoloay's Avatar
    Hello everyone.

    A friend of mine is encountering issues with the connections on his 820. Below are some details:
    • In good 3G coverage, the device shows H or H+ but it doesn't connect in browser/ facebook/ twitter, etc. Even in average WiFi coverage.
    • Most of the time, both data and wireless connections are turned on.

    What should he do to the device? Any steps? Could it be a defective unit (although he denied the presence of this issue in the first days of using it)?

    Thanks.

    EDIT 1: When both Data and wireless connections are on, it seems that data connection dominates and fails to connect. Thus, the problem is in the data connection. As for the APNs, they are already automatically set by the device AFAIK.
    Last edited by Technoloay; 10-03-2013 at 03:06 PM.
    10-03-2013 02:01 PM
  2. unstoppablekem's Avatar
    Have him try soft resetting or restoring the phone. If that doesn't work, I think it is defective. Unless he bought it unlocked or whatever and didn't setup the apn's?
    10-03-2013 02:09 PM
  3. Technoloay's Avatar
    Unless he bought it unlocked or whatever and didn't setup the apn's?
    Yes. In here, they only sell it as a country variant. Aren't the APN's automatically set? I mean like how does the phone recognize the data connection type and connect through it at the set up?
    10-03-2013 02:38 PM

Similar Threads

  1. Accessory Review: ProClip USA car mount and the Lumia 1020
    By thoughtfix in forum Windows Phones
    Replies: 5
    Last Post: 10-15-2013, 02:00 AM
  2. Facebook security error on wp8
    By dangerous_dave in forum Other Operating Systems
    Replies: 13
    Last Post: 10-10-2013, 08:03 AM
  3. Viber Issue
    By DollOfWar in forum General Phone Discussion
    Replies: 2
    Last Post: 10-04-2013, 03:17 PM
  4. Is Class 10 micro SD supported in lumia 820??
    By SaiKiran7474 in forum Windows Phones
    Replies: 4
    Last Post: 10-04-2013, 07:24 AM
  5. IE back button getting stuck on some pages
    By michail71 in forum Other Operating Systems
    Replies: 11
    Last Post: 10-03-2013, 09:34 PM
LINK TO POST COPIED TO CLIPBOARD