1. AhmedEzz's Avatar
    my lumia started acting weird a month ago

    first it kept on losing network "i am on 3G/2G network" i did all possible troubleshooting. changed sim, changed line, changed operator, resetted, flushed GDR2.


    after alot of investigation i found out that whenever i try to put the phone on 2G network it can't register to the network "used to work fine" problem is when i am in low signal or inside building or roaming from one cell tower to another it seems that the phone try to find 2G network so it gets into stalled mode with no connection and doesn't work back unless i restarted it or went to setting and refreshed the network list.

    any idea?
    10-13-2013 10:59 AM
  2. pankaj981's Avatar
    Check for the following things before checking with your operator:

    1. Settings >> Cellular >> Network Selection >> Automatic
    2. Settings >> Cellular >> Highest Connection Speed >> Set to whatever is the highest (I am guessing 3G)
    3. Phone >> Dial ##3282# (if a new menu pops up, proceed, else go to 4.) >> Press on three ... at the bottom >> Settings >> Polling Frequency = 3, Network Type = Automatic, Everything else = OFF >> Back Button >> Windows button
    4. Settings >> Cellular >> If you see Add Internet APN and/or Add MMS APN, open each one and delete them
    5. Settings >> Access Point >> Select your operator

    Reboot and check if you hit jackpot??
    10-13-2013 05:51 PM
  3. AhmedEzz's Avatar
    Tried all that with no luck. It works fine when choosing 3G dies when choosing 2G
    10-13-2013 07:11 PM
  4. AhmedEzz's Avatar
    B
    u
    m
    p
    10-15-2013 12:55 PM
  5. AhmedEzz's Avatar
    Any idea what could my problem be?
    10-18-2013 07:19 PM
  6. Parikshit Saxena's Avatar
    Hey,

    I am having the exact same issue... Did you find a fix to it?

    Thanks!
    Parik****
    03-22-2014 07:59 AM
  7. AhmedEzz's Avatar
    At the end Nokia care changed the RF antenna
    09-21-2014 08:54 PM
  8. psoham777's Avatar
    Reset your phone, I had the exact same problem but with 3g, resetting will most probably sort it out
    09-21-2014 08:59 PM

Similar Threads

  1. Lumia 920 vs HTC 8X
    By TheShez in forum Windows Phones
    Replies: 9
    Last Post: 10-26-2013, 11:23 AM
  2. Can't play 920 videos on the 1020.
    By Roger Donald1 in forum Windows Phones
    Replies: 5
    Last Post: 10-13-2013, 09:35 PM
  3. Easily fix your bricked lumia at home!
    By jojapath in forum Windows Phones
    Replies: 2
    Last Post: 10-13-2013, 10:06 AM
  4. Initial thoughts on lumia 925
    By khader_moham in forum Windows Phones
    Replies: 1
    Last Post: 10-13-2013, 06:41 AM
  5. Selling a Nokia Lumia 900... What to do?
    By drgeri in forum Windows Central Archive
    Replies: 2
    Last Post: 10-13-2013, 04:18 AM
LINK TO POST COPIED TO CLIPBOARD