1. jleebiker's Avatar
    Is anyone else having problems with their compass on the 928? Here+ City Lens says I don't have a compass. I tried d/l another compass app and it also said I didn't have a compass. Is there a util I can d/l that will check to make sure the compass is working correctly? I do NOT think this is a result of GD3. I think I noticed this prior to the upgrade.
    10-15-2013 10:03 AM
  2. hopmedic's Avatar
    Just tried it. I get a "problem" when I tap "sign in". And initially when I tried to see things on the AR screen, it wouldn't load any POIs. I uninstalled/reinstalled. While reinstalling, I looked in Drive and Maps, and it wouldn't sign in on either of those, either (and this is after GDR3 update, but without having restarted since the update). I restarted the phone, and both of those apps both have me signed in to Nokia now, but I still get a problem when I try to sign in to City Lens. The compass does work, though, after going through the calibration.
    10-15-2013 10:17 AM
  3. jleebiker's Avatar
    Thanks Hop, when I try to reinstall City Lens, it says I don't have the hardware for this app and it won't even let me install from the Store.
    10-15-2013 11:41 AM
  4. jleebiker's Avatar
    And now, I can't download anything. Seems there's a problem with Microsoft Account Services. Sigh.
    10-15-2013 11:48 AM
  5. hopmedic's Avatar
    That's what it sounds like. I hate to say it, but my guess is that a hard reset is in your future.
    10-15-2013 01:39 PM
  6. jleebiker's Avatar
    Ok, it might have just been a glitch. I can d/l apps now. However, when I download any compass app, they say compass isn't detected. :-(
    10-15-2013 03:41 PM
  7. hopmedic's Avatar
    The tech in me says that there's going to need to be a hard reset - either to fix the problem, or to prove that the problem isn't software so the phone can get replaced.
    10-16-2013 08:02 AM
  8. DavidinCT's Avatar
    Go on the homepage, there is a free app Jack of all tools free today(for the next 24 hours)......It has a compass with other tools that seems to work pretty well on my 928..
    aximtreo likes this.
    10-16-2013 08:36 AM
  9. hopmedic's Avatar
    Someone didn't read.........
    10-16-2013 09:23 AM
  10. palaudawg's Avatar
    I had the same issue and had to get a replacement from Verizon. I tried a hard reset but during the reset it got stuck on the spinning gears and never recovered. Search the 928 forum and you will find that a few other members had a similar issue.
    10-18-2013 02:06 PM
  11. jleebiker's Avatar
    UPDATE: I did a hard reset and the compass came back to life. Now the process re-load all my apps and get everything the way I had them before the reset. ;-)
    hopmedic and palaudawg like this.
    10-24-2013 02:31 PM
  12. hopmedic's Avatar
    Glad to hear it.
    jleebiker likes this.
    10-24-2013 02:32 PM
  13. TheJoester09's Avatar
    I've had all kinds of problems with my COMPAS every since the Amber update. It just refuses to calibrate, and a hard reset does nothing to fix it. I probably need to get it replaced, but I JUST made a warranty claim so I really don't feel like going through the process again. I guess I'll just have to suck it up, but this makes it impossible to use Photosynth, which is one of my favorite apps to show off. :(
    10-24-2013 02:44 PM
  14. hopmedic's Avatar
    Yeah, I love Photosynth.
    10-24-2013 03:02 PM
  15. Future Fossil's Avatar
    Mine did the same thing. Any app dependent on a compass didn't work. It's most certainly a hardware issue. Mine was still under warranty. Verizon replaced it and I was back like new and set up again within 48 hours
    10-28-2013 08:22 PM
  16. jleebiker's Avatar
    You still had to re-setup all your apps and settings though didn't you?
    10-29-2013 02:55 PM
  17. Future Fossil's Avatar
    Well... all the major things, like app downloads and contacts came flying into the phone as long as you backed them up. Tweaking of the app settings and Start screen must be re-tweaked. My point is, if a variety of apps dependent on the internal gyroscope don't seem to be working, then you are certainly looking at a hardware problem and the phone will have to be replaced. Luckily, mine was still under warranty and I was satisfied at the speed in which Verizon replaced the phone..
    10-31-2013 10:51 PM
  18. jleebiker's Avatar
    Mine is still under warranty as well, but they wanted me to do a hard reset first before replacing it. Hard reset resolved it. Wondering if this will happen again in the future and I should just replace it now while under warranty.
    11-01-2013 10:40 AM
  19. hopmedic's Avatar
    You've got plenty of time for the warranty, jlee. It won't expire until May 16, assuming you bought on launch day. Later if not.
    jleebiker likes this.
    11-01-2013 12:03 PM
  20. jleebiker's Avatar
    Yep. If this happens again, I'm taking it back. No further troubleshooting necessary.
    11-03-2013 08:59 AM

Similar Threads

  1. Lumia 928 Internet Sharing weird situation
    By mariusmuntean in forum Windows Phones
    Replies: 15
    Last Post: 04-07-2014, 03:44 AM
  2. Gdr3 on 620
    By Subin Abraham1 in forum Developers Corner
    Replies: 21
    Last Post: 11-04-2013, 12:15 PM
  3. Lumia 928 headset issues
    By Mistuke in forum Windows Phones
    Replies: 2
    Last Post: 10-25-2013, 09:59 AM
  4. Can we attach to mail on Lumia720
    By ravi jami in forum Windows Phones
    Replies: 4
    Last Post: 10-15-2013, 10:18 AM
  5. Can't see the right hand side of photos on Facebook with gdr3
    By Darren Walsh in forum Other Operating Systems
    Replies: 1
    Last Post: 10-15-2013, 07:05 AM