Surface Pro 7 deal! Save big at Amazon right now

  1. agarcia59's Avatar
    Noticed my phone was discharging faster than usual today, Went from 64% to 17% in about 20 minutes. This isn't a new problem. One issue though, when I put it on its wireless charging pad, 3 minutes later, I got the indication through my battery app that charging was complete!
    Checked my app and the battery indicator in systems, both at 100%

    My battery app said 144% charging speed. Crazy right? Anyone else had this happen?
    Attached Thumbnails wp_ss_20131119_0001.png  
    11-19-2013 03:43 PM
  2. wapoz's Avatar
    Wow, that's only 2% away from plaid speed! *Spaceballs reference for them young whipper snappers out there*
    11-19-2013 03:49 PM
  3. agarcia59's Avatar
    Still seeing this 144.8 Percent on charging. Hoping the most recent update fixes it!
    11-20-2013 01:25 AM
  4. Hasan Jawad's Avatar
    3rd party battery apps dont work well on lumia 920 after gdr2 update i guess, having the same problem so un installed them all. but battery still doesnt show the correct indicator and dit doesnt charge as well. it will never go to 100% it will just be stuck at around 86 or 90s or sometimes 60s
    11-26-2013 07:21 AM
  5. archersvalley's Avatar
    All good with my battery after all the updates on my 920. And insider app works perfectly for me!
    11-26-2013 07:31 AM

Similar Threads

  1. [Resolved] charging L620
    By azedddine in forum Windows Phones
    Replies: 3
    Last Post: 11-21-2013, 05:18 AM
  2. Need help with 1020 Camera Grip charging
    By Majin Static in forum Windows Phones
    Replies: 2
    Last Post: 11-18-2013, 06:05 AM
  3. Plugged in, no charge
    By Bigfireq in forum Microsoft Surface Pro
    Replies: 1
    Last Post: 11-17-2013, 03:14 PM
  4. I fixed my wireless charging shell.
    By shaddup in forum Windows Phones
    Replies: 1
    Last Post: 11-17-2013, 01:31 AM
LINK TO POST COPIED TO CLIPBOARD