1. stellarroar's Avatar
    No clue why but activating a lockscreen password on my 620 makes the battery drain much faster than usual. I'm very sure of it because the battery drains about 2% every hour while normally it takes a couple hours to drain that much. I should also mention that I got my screen repaired recently thanks to installing the Amber update which completely screwed up the touch. I don't know if this issue was present before the update or before getting my phone repaired as I never used this feature feature then. Has anybody here experienced this on their phone or have any tips? Thank you in advance!
    11-22-2013 12:09 PM
  2. Manikanta Reddy's Avatar
    Thats interesting , never thought of it before , let me give it a try and report.
    11-22-2013 12:28 PM
  3. eroselim's Avatar
    Since day 1 I had my lockscreen set for a password when open. Didn't notice this kind of problem. It might happen because of the replacement of your screen. Though, what I notice is the sudden unresponsive of touch wherein you'll need to lock the phone again, and unlock it again.
    11-28-2013 06:12 PM
  4. stellarroar's Avatar
    Since day 1 I had my lockscreen set for a password when open. Didn't notice this kind of problem. It might happen because of the replacement of your screen. Though, what I notice is the sudden unresponsive of touch wherein you'll need to lock the phone again, and unlock it again.
    Yea that happens sometimes to me too. My problem though got fixed with a hard reset.
    12-01-2013 07:38 AM

Similar Threads

  1. Can't access to apps after pressing back too fast
    By Sean Sabe in forum Other Operating Systems
    Replies: 1
    Last Post: 12-01-2013, 03:41 PM
  2. Replies: 2
    Last Post: 11-26-2013, 06:17 AM
  3. iPhone 4s short battery life
    By yeto in forum iPhone
    Replies: 2
    Last Post: 11-22-2013, 10:17 AM
  4. 2G or 3G to save battery life.
    By Sean Sabe in forum Other Operating Systems
    Replies: 1
    Last Post: 11-22-2013, 12:35 AM
  5. battery not staying at 100% after unplugging
    By mach1man in forum Windows Phones
    Replies: 2
    Last Post: 11-21-2013, 08:11 AM
LINK TO POST COPIED TO CLIPBOARD