04-05-2016 11:55 PM
357 ... 1112131415
tools
  1. morrisonbrett's Avatar
    Same issue here on my unocked ATT 1020. I've tried two foreign SIMs from Amazon. Every time I insert a SIM (foreign or T-Mobile), the phone reboots. No Internet Sharing.
    12-22-2014 12:45 AM
  2. Fredrik Winsnes's Avatar
    This process does not work with a T-Mobile card from Slovenia
    12-31-2014 12:39 AM
  3. silvertonesx24's Avatar
    Same issue here on my unocked ATT 1020. I've tried two foreign SIMs from Amazon. Every time I insert a SIM (foreign or T-Mobile), the phone reboots. No Internet Sharing.
    This happened to me when I mistyped manual APN settings. Clear these and see what happens.
    01-02-2015 12:49 PM
  4. Abba Bbba's Avatar
    the access point does not work with windows phone 8.1 on my unlocked AT&T lumia 1520. Any work around?
    01-03-2015 02:23 PM
  5. shantahan's Avatar
    Thanks for the suggestion! I tried it but no luck for me:

    I deleted the manual APN, still reboots on SIM insert.

    I then hard reset my phone and it still reboots on SIM insert.

    I noticed that there is a difference between my phone HW revision and that of matteni: in another copy of this thread (I think on xda-developers) he says he has HW rev 3.3.0.2. I have rev 3.3.0.0. Maybe this is why?
    01-05-2015 11:21 PM
  6. woe2therepublic's Avatar
    i actually have hardware 3.3.0.2 and it still reboots so its not that
    shantahan likes this.
    01-08-2015 02:29 AM
  7. armodons's Avatar
    Not sure why but my AT&T Lumia 1020 does not reboot when I remove/insert the SIM card while the phone is on. It recognizes the T-mobile SIM and connects and allows tethering following Matteni's post...
    01-09-2015 09:08 PM
  8. Zerodrag's Avatar
    I personally have a unlocked AT&T Lumia 1020 and a AT&T 925 both running Cyan and can use my T-Mobile Internet Sharing now.

    Takes me less than 2 minutes personally

    Bad news: You will still need a foreign SIM AND you will have to do this after every reboot. I dont reboot very often so this is not a deal breaker for me - to have this great functionality back.

    Here are the instructions. Please note you never need reboot your phone during this process:
    1. Install Access Point Software (If you are doing this for the first time AND if you have this "app" - you can SKIP this step). Otherwise do a google search for "windows phone access point" from your phone and install it now.
    2. Replace current T-Mobile SIM with foreign SIM (I have a $10 Pay as You Go Orange UK card off Amazon that I carefully trimmed to the correct size using scissors)
    3. Go to access point under settings and pick a foreign access point (I had about 5 to choose from - I don't believe it matters so long as it isn't a US one or T-Mobile)
    4. Go to airplane mode
    5. Go to date/time settings and take off automatic updates. Then set the current year to 2112 or higher. You read that correctly.
    6. Go back to access point (it will now ask to uninstall or buy - you want to uninstall)
    7. Swap in T-Mobile SIM
    8. Setup date/time back to automatic
    9. Go to Cellular under settings and turn data connection ON (will ask to go out of airplane mode - say OK)
    10. Turn on internet sharing under settings (It works!)

    I know this has been a huge pain for Lumia 920 / 925 / 1020 people bringing their AT&T Branded device to other carriers like T-Mobile.

    If you have this issue and can test/post back - I would appreciate it.
    Thanks! This worked for me. AT&T unlocked Lumia 920 used Orange SIM card from Amazon. Though replacing SIM while phone was on did not allow the phone to detect the new SIM so I had to shutdown in between SIM swaps. Before this, I used to get the "...dial 611..." or something message whenever I tried enabling internet sharing.
    01-13-2015 07:22 PM
  9. AV2RY's Avatar
    Nice! Works again. After each major update my Internet sharing settings get messed up and I cant enable it anymore. Few month ago this trick didnt work but after Access Point and Network+ updates it started working again. Last month it broke again when I received update (not Denim) from Verizon (Lumia 928 - on T-mobile) and todays Access Point and Network+ update didnt fix it too. I tried this again and it WORKS! Thank you
    01-16-2015 01:30 PM
  10. shantahan's Avatar
    An update --

    I used Nokia Care Suite to revert my unlocked, AT&T branded Nokia Lumia 1020 (RM-877) to WP 8.0 (8.0.10517.150, firmware rev 3051.40000.1346.0001). I used the original instructions at the beginning of this thread and it does work, as it should. I did want to note that the phone does reset itself when putting in a SIM, even at this old FW / ROM version.

    I am going to update the phone and see what happens. I don't expect any miracles though.


    Update 2 --
    WP 8.0.10532.166
    FW: 3051.40000.1346.0001 (according to About)
    Label ID: 3051.40000.1346.10288 (Extras + Info) Lumia Black

    Internet sharing still works, didn't do any SIM change or anything


    Update 3 -- direct to Cyan
    WP 8.10.12393.890
    FW: 3051.50009.1425.2001
    Radio SW version: 3.2.04059.1
    Core Build ID (extras + info): 3051.50009.1425.10367

    Internet Sharing does not work after restart. Have yet to try method in post 1 or matteni's

    Well. I tried matteni's method. My phone does not reboot on SIM insertion anymore (I don't know why). But Internet sharing works!

    Now, should I try to use developer preview?

    Update 4:
    First Dev Preview
    WP 8.10.12400.899
    matteni's method still works.

    Update 5:
    WP 8.10.14157.200 (windows phone 8.1 update 1)
    matteni's method still works!

    Update 6 (final, up to latest dev preview version)
    WP 8.10.14219.341
    still works!

    A note: Sometimes, right after I've done matteni's trick, and try to turn on internet sharing, it will say: "Internet sharing isn't currently allowed." After a bit (a few minutes.... maybe more?) it will work. I'm not sure what's going on there.
    I took out the T-mobile SIM and then put it back in and it worked right away. I am not sure if that'll be consistent, but something to try.

    But overall, great!
    Last edited by shantahan; 05-16-2015 at 02:53 AM.
    01-17-2015 10:36 AM
  11. Zerodrag's Avatar
    Just an update... I realized that internet sharing works after initially booting up the phone, but later cannot be enabled (has message "There's no cellular data connection to share right now...") after a certain amount of time. If I reboot the phone, I can use it again with the same condition.


    Edit:
    I found that turning off data connection then back on also brings internet sharing back, rather than rebooting phone to do it.
    Last edited by Zerodrag; 01-19-2015 at 04:58 PM.
    jojapath likes this.
    01-18-2015 02:31 PM
  12. azlkk's Avatar
    I'd love to know why I can Internet Share with my unlocked AT&T 920 overseas (Golan Telecom in Israel) but not back in the states on T-Mobile. I've tried the steps above to no avail state-side but all I need to do overseas is swap the SIM card.
    01-19-2015 10:29 AM
  13. Fred Wilson2's Avatar
    Then that, most certainly, means that it's T-Mobile that's "blocking" it on that phone.

    Fred


    I'd love to know why I can Internet Share with my unlocked AT&T 920 overseas (Golan Telecom in Israel) but not back in the states on T-Mobile. I've tried the steps above to no avail state-side but all I need to do overseas is swap the SIM card.
    01-19-2015 12:47 PM
  14. azlkk's Avatar
    T-Mobile tells me that I have that feature. I figure it's AT&T continuing to haunt me. I'll just get a newer T-Mobile phone if MS ever comes out with a decent upgrade.
    CamiKitti likes this.
    01-20-2015 01:16 AM
  15. yipsan's Avatar
    Just to add a datapoint for reference. I reverted back to 8.0 and black for quite some time to have internet sharing. After reading the recent updates here, I thought I would give it a try and updated to Cyan. After updating to Cyan, the phone did not reboot on sim removal and insertion, which is different to when on 8.0 black. However, matteni's method did not work for my phone. It may work for a T-Mo sim, but not my Airvoice sim. My phone is an unlocked ATT 1020. Hope this helps others. Now I am off to reverting back to 8.0.
    01-21-2015 05:52 PM
  16. yipsan's Avatar
    Further to my last post, I tried to get on dev preview with 8.0 black. I reverted back to 8.0 black, then signed up for dev preview. Then updated under dev preview. The first update brought me to cyan. I was not sure if this cyan is the same as the formal release cyan. I tried Internet sharing at this point, it didn't work. But I also didn't go through matteni's method. I was feeling frustrated at the time thinking that even on dev preview, the formal cyan is forced onto users.
    For whatever reason, I kept updating 2 more times, now the phone is on 8.10.14157.200, then I went through matteni's method, then it worked! I used an HK 3 sim as the foreign sim, then tried sharing with a lycamobile us sim and then an airvoice sim. Both worked. Now I am not sure if I should update further and if a reboot will render back to no sharing.
    Hope this helps others.
    01-23-2015 10:26 AM
  17. SiriuS_r3d's Avatar
    I am having similar issue. My device Lumia 822 is unlocked and I am using it in india. After the Denim update from Verizon, the accesspoint app doesn't open and Internet sharing is not working.

    When I try to turn on the internet sharing, it says "Internet sharing isn't currently available". All the above mentioned steps not working since I am not able to open the access point setting.
    02-02-2015 02:29 AM
  18. Paul Kinslow's Avatar
    As of 3-23-15, this does not work for me with 2 Lumia 1020s that have the latest software and firmware installed. I have tried these instructions exactly, and tried a number of variations to these steps that were found on the internet. I still always get the erroneous message "Your current data plan doesn't include Internet sharing..."
    03-23-2015 02:04 PM
  19. Marcos Hidalgo's Avatar
    I just did it on my Rogers 1020 on T-Mobile with a EE sim card. Freaking awesome!
    04-02-2015 03:37 PM
  20. sleeve22's Avatar
    Glad to hear it still works.
    04-02-2015 04:06 PM
  21. A A Kadakia's Avatar
    Does not work on my Lumia 820 with Airtel (India) sim
    04-06-2015 02:13 AM
  22. CamiKitti's Avatar
    Didn't work with unlocked Lumia 920 and Vodafone PAYG sim.
    04-18-2015 12:51 AM
  23. Maceart's Avatar
    Worked with prepaid UK EE SIM card off Ebay.

    Tested on both LTE and 4G connections and both worked for Internet Sharing on a Rogers Lumia 920 with Denim.

    Not sure why on my laptop connected to the tethered connection teamviewer/AIM lite doesn't work...
    04-21-2015 11:07 AM
  24. pankaj981's Avatar
    Worked with an unlocked Rogers Lumia 920 w/ Denim on a Cricket Wireless SIM, foreign SIM used was an Airtel SIM
    04-27-2015 09:46 PM
  25. PYY's Avatar
    After forced update to Denim, the foreign SIM hack no longer works :(. Access Point app is even more crappy and internet/mms doesn't work at all without it, even with correctly entered in APN/MMs settings on the SIM.
    05-15-2015 12:45 PM
357 ... 1112131415

Similar Threads

  1. VOIP Softphone on Surface 2 Available?
    By jiovine in forum Microsoft Surface Laptop
    Replies: 6
    Last Post: 02-20-2014, 06:23 PM
  2. Infinite Switching on and off! Help please!
    By James Smith23 in forum Windows Central Archive
    Replies: 10
    Last Post: 11-26-2013, 10:39 AM
  3. Replies: 9
    Last Post: 11-23-2013, 07:01 AM
  4. tone control diagnostic code not working
    By phatsoballer in forum Windows Phones
    Replies: 0
    Last Post: 11-22-2013, 10:12 PM
  5. Old SIM, New Phone?!?!
    By MichaelBanning in forum Windows Phones
    Replies: 1
    Last Post: 11-22-2013, 08:07 PM
LINK TO POST COPIED TO CLIPBOARD