1. DaveP84's Avatar
    Hi,

    I've just got a vodafone Lumia 520 and I can't use the internet with it. When I click IE a blank tab is displayed and nothing loads, I click the search bar and type something in and hit enter and it briefly goes back to the tab, attempts to pull the data and then just exits back to the main menu. This is also the same for some other applications that I assume need internet. I click Vodafone Hub, it exits back out.

    The facebook application works, youtube doesn't, YouTube HD works but if I click "sign in" it exits.

    I've tried switching off mobile data and using wifi only
    I've tried soft reset
    I've tried hard reset
    Taken the battery and sim out
    Experimented with numerous settings for IE (open in new tab, allow all cookies, opened a new tab and closed the old one)
    Removed all applications that I could including Vodafone Hub

    Nothing has worked, does anyone know what the problem is?

    The phone is only 2 days old, so always had this problem. :(
    02-25-2014 02:37 AM
  2. Laura Knotek's Avatar
    Have you tried turning off WiFi and using mobile network data?
    02-25-2014 03:00 AM
  3. DaveP84's Avatar
    Have you tried turning off WiFi and using mobile network data?
    Yes, same result
    02-25-2014 03:04 AM
  4. DaveP84's Avatar
    I've checked for updates, its downloading them now
    02-25-2014 03:05 AM
  5. DaveP84's Avatar
    update downloaded but could not be installed. ffs.
    02-25-2014 03:30 AM
  6. shmsnh's Avatar
    update downloaded but could not be installed. ffs.
    What's the error?
    02-25-2014 09:57 AM
  7. DaveP84's Avatar
    What's the error?
    Update downloaded but could not be opened (Error code)

    I forget what the error code is, but it seems to be a common problem every update, people experienced it updated to Amber as well as Black. Some people say it is a space issue though I have plenty of space and others say you just keep trying and after about 30 attempts it might just decide to work.

    Internet still broken...
    02-26-2014 01:44 PM
  8. DaveP84's Avatar
    An update to Black solved the issue for me, I had to download Nokia Software Updater to do it though.

    Back up my phones apps etc in settings > backup
    Downloaded and installed NSU 4.1 on a laptop
    Switched the phone off and connected it via the cable to the laptop
    Switched the phone on and Windows detected and installed drivers
    Fired up NSU 4.1 and clicked update

    Followed the instructions, all sorted. Store downloaded some app updates and everything so far works
    02-27-2014 03:04 AM

Similar Threads

  1. Anyone switch from Zune Pass to Xbox Music Pass?
    By psiu_glen in forum Windows Apps
    Replies: 9
    Last Post: 04-15-2014, 01:05 AM
  2. Surface Phone WP Flagship: "Corvette Strategy" Best Way To Increase WP Market Share in US
    By Washed Up Former Child Actor in forum Other Operating Systems
    Replies: 13
    Last Post: 02-27-2014, 12:19 PM
  3. New Lumia Phones in WMC?
    By nitin88 in forum The "Off Topic" Lounge
    Replies: 5
    Last Post: 02-26-2014, 04:18 PM
  4. How to turn on LED flashlight?
    By Gary Anderson5 in forum Windows Phones
    Replies: 5
    Last Post: 02-25-2014, 04:30 PM
LINK TO POST COPIED TO CLIPBOARD