1. Asharon Baltazar's Avatar
    Has anyone experienced skipped animations on the Nokia Lumia 620 running WP8.1 and the refreshing of Live Tiles? Also everything just goes blank on the Start Screen and then it takes a few seconds to refresh. And everything is just so S-L-O-W (not that slow but slow). Has anyone found a fix for this or is this just some technical issues with WP8.1? Windows Phone 8 was super fast, no stuttering whatsoever, even when exiting from demanding apps. But now... it's a joke .
    Thanks a lot,
    Asharon Baltazar and greetings from Israel!
    Dario Federico and JustRay76 like this.
    04-17-2014 07:03 AM
  2. anon(8055491)'s Avatar
    the same on my 620.
    Asharon Baltazar likes this.
    04-17-2014 08:48 AM
  3. colinkiama's Avatar
    Has anyone experienced skipped animations on the Nokia Lumia 620 running WP8.1 and the refreshing of Live Tiles? Also everything just goes blank on the Start Screen and then it takes a few seconds to refresh. And everything is just so S-L-O-W (not that slow but slow). Has anyone found a fix for this or is this just some technical issues with WP8.1? Windows Phone 8 was super fast, no stuttering whatsoever, even when exiting from demanding apps. But now... it's a joke .
    Thanks a lot,
    Asharon Baltazar and greetings from Israel!
    I know this sounds so cliché but, Have you tried rebooting your phone?
    04-19-2014 10:17 AM
  4. xandros9's Avatar
    Yea even my higher-up 920 has felt bogged down a bit. I'd wait a couple days for it to settle and try a soft reset. (holding power + vol down until it reboots)
    It's not as same, but I feel the extra features are more than worth it.
    Asharon Baltazar likes this.
    04-19-2014 01:17 PM
  5. LTTG's Avatar
    I have that on my 720 too...
    Asharon Baltazar likes this.
    04-19-2014 01:20 PM
  6. anon(8055491)'s Avatar
    i hard resetted my phone but it lags the refreshing of the live tiles
    04-20-2014 04:56 AM
  7. colinkiama's Avatar
    I think that they changed the way the live tiles load so that SD cards can be supported. I have a class 10 but at times it can take a few seconds for all the tiles to load. I'm not sure how it's like on a 1520 though.
    04-20-2014 06:00 AM
  8. Asharon Baltazar's Avatar
    I know this sounds so cliché but, Have you tried rebooting your phone?
    Yep. But I started getting used to the lag and I'm sure it'll be fine 😃.
    06-10-2014 11:33 AM
  9. vijenderkt's Avatar
    Ya same here on my 620.....
    06-15-2014 11:10 AM
  10. Asharon Baltazar's Avatar
    I finally got it!!! After losing my memory card (f@%k that sh^t!!!), I had to reinstall all the apps on my phone.. to my phone! And when I did that, the apps' live tiles stopped refreshing! Great job!
    06-28-2014 01:19 PM
  11. David P2's Avatar
    I've had nothing like that on my 620 running 8.1.
    06-28-2014 01:23 PM

Similar Threads

  1. Maps on SD card WP8.1
    By Apostolos Tsimogiannis in forum Other Operating Systems
    Replies: 14
    Last Post: 06-24-2015, 10:12 AM
  2. Where are Microsoft collecting bug reports for WP8.1?
    By Sabre Wulf in forum Other Operating Systems
    Replies: 3
    Last Post: 07-06-2014, 01:25 AM
  3. VPN on Windows Phone 8.1
    By Dave Catherall in forum Other Operating Systems
    Replies: 8
    Last Post: 06-13-2014, 03:59 PM
  4. Music and Videos Hub still accessible in WP8.1
    By lpforthewin in forum Other Operating Systems
    Replies: 1
    Last Post: 04-17-2014, 06:48 AM
  5. Win the chance to join the aquanauts from Mission 31 with Nokia
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 04-17-2014, 05:40 AM
LINK TO POST COPIED TO CLIPBOARD