1. raccoonWind's Avatar
    Hi all.
    I am with Wind Mobile Canada and I use Nokia Lumia 920 (Rogers model, sim unlocked). At some point (I believe Feb 2014) Internet Sharing stopped working. It always gives error message "no cellular data".
    Anyone with 920 on Wind? Same issue?

    I spoke with Wind today, they told me to call Nokia Support. Some sources say that Rogers has separate APN for tethering and this is "hardcocded" to phone's OS.

    Shall I install european dev ROM? Any downsides?

    Feel puzzled...
    06-10-2014 07:22 PM
  2. JamesPTao's Avatar
    Hi all.
    I am with Wind Mobile Canada and I use Nokia Lumia 920 (Rogers model, sim unlocked). At some point (I believe Feb 2014) Internet Sharing stopped working. It always gives error message "no cellular data".
    Anyone with 920 on Wind? Same issue?

    I spoke with Wind today, they told me to call Nokia Support. Some sources say that Rogers has separate APN for tethering and this is "hardcocded" to phone's OS.

    Shall I install european dev ROM? Any downsides?

    Feel puzzled...
    Does your provider allow tethering with you current plan as is. My 920 under at&t did the same thing until they started mobile share. In my case before this at&t locked out the ability unless you payed for a tethering plan.
    06-10-2014 07:37 PM
  3. raccoonWind's Avatar
    My carrier (Wind Mobile Canada) does allow tethering for all plans with data.
    06-10-2014 08:38 PM
  4. raccoonWind's Avatar
    Just a conversation with Nokia. They tell me to use 'Nokia Software Recovery Tool' to reinstall OS. They confirm that such problem exists and Rogers made modifications to OS. Tonight I will try to install this EURO DEV ROM (059R4H6).
    06-11-2014 07:55 PM
  5. raccoonWind's Avatar
    So I have recovered phone OS as Nokia suggested. Bingo! Internet Sharing now working! OS recovered - Lumia Black, so now I am installing 8.1 dev preview. Lets see if tethering works on wp8.1
    06-12-2014 01:49 AM
  6. jojapath's Avatar
    All you had to do was to download and install the access point app, create a fake APN and turn it on then turn the WIND APN back on...
    06-12-2014 09:24 PM
  7. raccoonWind's Avatar
    So. 8.1 dev preview Interner Sharing works fine. MMS send/receive also works. It isnt clear what actually was source of my trouble.
    Jojapath, I tried almost everything including what you suggested and even uninstalling of access point (date future trick).

    The only thing that really helped - OS recovery
    jojapath likes this.
    06-13-2014 04:13 PM
  8. rudypoochris's Avatar
    Just a conversation with Nokia. They tell me to use 'Nokia Software Recovery Tool' to reinstall OS. They confirm that such problem exists and Rogers made modifications to OS. Tonight I will try to install this EURO DEV ROM (059R4H6).
    Where do you find these ROMs?
    06-15-2014 04:16 AM
  9. raccoonWind's Avatar
    I didnt try this yet. Here is post explaining the thing in detail:
    http://forums.windowscentral.com/nok...0-results.html
    06-24-2014 05:41 PM

Similar Threads

  1. Turn off screen appears every time (Nokia Lumia 520)
    By Nick Schaafsma in forum Windows Phones
    Replies: 11
    Last Post: 09-10-2014, 02:43 PM
  2. Replies: 12
    Last Post: 07-10-2014, 11:23 AM
  3. lumia 920 or lumia 925
    By Brian Galeas1 in forum Windows Phones
    Replies: 6
    Last Post: 06-17-2014, 06:36 AM
  4. nokia lumia 820 storyteller crash
    By AnestisL820 in forum Windows Phones
    Replies: 2
    Last Post: 06-12-2014, 12:08 AM
  5. Please help on 920. No Black features, but phone states Up-to-date
    By vartanarsen in forum Other Operating Systems
    Replies: 4
    Last Post: 06-11-2014, 08:13 AM
LINK TO POST COPIED TO CLIPBOARD