1. drjdrjdrjdrjdrj's Avatar
    My phone upgraded to Cyan last week - seemingly without any issues except that Battery Saver won't run.

    It's listed in settings but doesn't do anything when touched (except it recedes slightly). It's currently saying:

    battery saver
    extend battery life, 79 battery left

    ... so something's working in the background.

    It's listed in the alphabetical apps list but again nothing happens when it's pressed (except it recedes slightly). If I press and hold the only option is "pin to start".

    If I select that option it appears at the bottom of the start screen but is "greyed out" and won't start from there either - though the tile can be moved, resized, or deleted.

    In Store it's showing as "installed" but when I click on it there are no options in the bottom menu as usual.

    I was hoping I could uninstall then reinstall but I can't find out how to uninstall.

    Any ideas or other routes to try to resolve please?

    I'm running Windows Phone Insider as the normal method of checking the battery. I also had another battery app running. I uninstalled both thinking there might be a conflict. There was no change so I've reinstalled the former in order to properly monitor the battery.

    Sim-free Nokia Lumia 920 - UK based - Tesco Mobile
    08-24-2014 11:31 AM
  2. Clay Knight's Avatar
    I ran into the same issue with a recent 8.1 update pushed from WP Insider for my 1520. I had to completely remove it from the device, then search for it in the Store and install it.
    08-24-2014 12:04 PM
  3. drjdrjdrjdrjdrj's Avatar
    Please explain what you mean you had to do.

    Do you mean you just removed the actual app? If so how does one do that when the "uninstall" option isn't showing?

    Or do you mean you removed the whole 8.1 update and reverted to 8.0 before reinstalling. If so I can't work out how to do that either. I might have to resort to that however if it's relatively straightforward...
    08-25-2014 02:50 AM
  4. drjdrjdrjdrjdrj's Avatar
    I stilll haven't been able to solve this one. Seemingly no way of uninstalling some programs...
    08-29-2014 02:47 AM
  5. volpenger's Avatar
    same problem with lumia 920 + cyan...
    08-29-2014 04:45 AM
  6. drjdrjdrjdrjdrj's Avatar
    Nice to know I'm not alone. If it's affecting others too then at least there might be an update to fix it if no one can come up with a solution.
    08-29-2014 05:55 AM
  7. Gunta's Avatar

    I have same problem, using Lumia 820.

    Anybody got some solution? If not, what kind of app would you suggest me, to control apps, that run in background?

    Thanks in advance!
    09-03-2014 04:50 AM
  8. bloguvirudu's Avatar
    I too got the exact same problem with my lumia 920.

    Battery saver is totally screwed up
    Incorrect battery level

    I did several refresh/reset still no luck. The worse thing is, i'm not hearing any acknowledgement of this issue either from Nokia or MS, and any upcoming update to fix it. Too bad.... My phone was golder prior to Cyan, all got screwed up now.
    09-14-2014 08:08 PM

Similar Threads

  1. Lumia 1520 Wont Turn On
    By WPCentral Question in forum Ask a Question
    Replies: 6
    Last Post: 09-24-2017, 06:51 PM
  2. Replies: 9
    Last Post: 08-26-2014, 06:25 AM
  3. Replies: 0
    Last Post: 08-24-2014, 11:27 AM
  4. The Charger port on my Nokia Lumia 928
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 08-24-2014, 11:23 AM
  5. The iconic lumia 920
    By bo_woods in forum Ask a Question
    Replies: 1
    Last Post: 08-24-2014, 11:15 AM