1. sup3r1or's Avatar
    I usually you my wireless charging pad to charge my phone when I'm at home. Today since morning I noticed weird thing, I put it on the charge and nothing will happen, then 3 minutes later phone makes beeping noise that it started charging, couple of mins later again off the charger. Second scenario pop on the charger sound goes like its charging comeback in an hour phone on same 24% and not charging.

    I have only 1 pad so I cant really test it with another one I wonder if its a phone or charging pad (I did drop phone recently but it was fine after that)

    Anyone else had similar issues?
    08-25-2014 10:36 AM
  2. dengwinters's Avatar
    Is it DT-601?

    If yes - check if it's on the correct side, be advised that it usually charges only when the phone is "on the spot" and it overheats easily (turning off charging until cooled down).
    Or better - replace with something like DT-900.
    08-25-2014 01:05 PM
  3. sup3r1or's Avatar
    No its not its DT-900 a big one. I worked flawlessly all the time. Now I pop phone on it white light comes up that its charging 30 seconds later it dissapears and thats it.
    08-26-2014 12:17 AM
  4. infinidim's Avatar
    I have noticed randomly that the 930 doesn't recognise the charging plates. I have both the DT-601 as well as the DT-900 and it seems to happen on both of them only very randomly. I also have the DC-50 as well which I use when I am travelling. I have noticed that when I restart my phone the issue goes away for quite a time - maybe it's a firmware issue that Microsoft Mobile (Nokia) need to address on the 930.

    Regards
    08-26-2014 07:01 AM
  5. sup3r1or's Avatar
    Alright so I went to Nokia Shop where I bought phone and charging plate. We tested it and it seems like charging plate is effed up. We got new one out and it worked without a hitch for 30 mins. So it surely seems like it is charging plate (I have not restarted my phone).

    It is a shame it is such a poor quality for that price. I just bought it 2 weeks ago and barely used it.
    08-26-2014 11:38 AM
  6. fbloise's Avatar
    mine is doing the same, with the DC-50, however I tested another Lumia (from a work colleague) and his 930 charges fine.

    Mine is only charging, and after a few minutes, from the DT-601. Same symptoms.
    09-19-2014 11:10 AM

Similar Threads

  1. Broken 1020 screen
    By DreadVenom in forum Windows Phones
    Replies: 7
    Last Post: 10-05-2014, 10:16 PM
  2. Lumia 930 not charging wirelessly
    By strongpa in forum Other Operating Systems
    Replies: 3
    Last Post: 08-25-2014, 11:10 AM
  3. access windowsphone.com when i tried to connect wireless!!
    By ahmedashraf_22 in forum Windows Phones
    Replies: 1
    Last Post: 08-24-2014, 09:20 AM
  4. [L822] Headphone jack is broken?
    By Chris Ramos in forum Ask a Question
    Replies: 0
    Last Post: 08-23-2014, 10:31 PM
  5. Nokia Lumia Icon/930 + DT900 wireless charging problem
    By Sensonic in forum Windows Phones
    Replies: 0
    Last Post: 08-23-2014, 03:37 AM
LINK TO POST COPIED TO CLIPBOARD