1. Noiralef's Avatar
    Hi everyone, I got my new Lumia 920 today, and it is driving me crazy. The main problem is that I cannot open any apps (like e.g. settings) - I just get a loading screen for a few seconds, then back to the home screen.

    Details:
    • I bought the phone "unused" from a private seller on amazon marketplace, and it did look unused to me (even though the packaging was opened). I couldn't find that "SIM key" but used a paperclip for inserting my SIM card.
      I applied a screen protector, but I tried removing it and the problems stayed.
    • When the phone first started (the battery was completely drained so it took a while until it was possible) I could go through the startup settings and connect to my Wifi. Creating a microsoft account didn't work for some reason so I skipped that. I allowed the phone to apply the settings provided by the carrier.
    • But now whenever I try to open something, I get a loading screen for a few seconds and then I'm just thrown back to my home screen. Exceptions are only preinstalled third-party apps like "HERE city lens" or "DB navigator" (for German trains) - they start but they don't seem to function properly. I can also get to the bing search menu, and there in the settings - but after a few seconds in those settings I'm thrown back to the home screen...
      Still, the tiles are apparently working. The messenger tile shows a few unread messages, in the people tile there's a lot going on and in the background of the photos tile there is some picture.
    • In the beginning, my battery symbol was constantly on "charging" even if the phone was unplugged. Right now it is the other way around.
    • I have not once been able to shut the phone down correctly. It always gets stuck either in "goodbye" or even before showing that screen. By pressing power + volume down I can get it to restart. (Afterwards I'm not connected to Wifi anymore.)
    • I tried doing a factory reset (power + v.down, hold v.down until exclamation mark, press v.up v.down power v.down). This time I kept the preselected language (which is German, the first time I changed it to English) and I was able to log into a Microsoft account that I had created on my laptop. But now everything is still the same as before.
    09-10-2014 04:37 PM
  2. DennisvdG's Avatar
    Sounds like you got screwed. :(
    fpostrow likes this.
    09-10-2014 04:54 PM
  3. Noiralef's Avatar
    That's what I'm afraid of, of course :( but I don't get it. I mean, it's not like it is a fake phone or it is bricked or whatever. The symptoms look more like a software problem to me...

    ****. Guess I'll have to try and return it. I'm not exactly hopeful...

    Edit: Update: I installed Nokia Software Recovery Tool, it recognizes the phone and offers to install a new software version. Let's see...
    Last edited by Noiralef; 09-10-2014 at 05:52 PM.
    09-10-2014 05:21 PM
  4. DennisvdG's Avatar
    That was my next suggestion, good luck!
    09-11-2014 12:44 AM
  5. Noiralef's Avatar
    After a few tries, the firmware update suddenly worked! Now I have Lumia Cyan and the phone is almost fully functional :) :) only the camera is not working...
    Seems like I'm not the only one with this problem, but I couldn't find a solution yet. I'll start a new topic for this.
    vsmh96 likes this.
    09-11-2014 07:19 AM
  6. DennisvdG's Avatar
    Alright, good luck. :)
    09-11-2014 12:08 PM

Similar Threads

  1. Lumia 1520 Battery loose 100% charge very fastly
    By WPCentral Question in forum Ask a Question
    Replies: 3
    Last Post: 09-11-2014, 03:07 AM
  2. Replies: 1
    Last Post: 09-10-2014, 06:52 PM
  3. Replies: 1
    Last Post: 09-10-2014, 06:37 PM
  4. Check out the new and improved mobile WPCentral site!
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 09-10-2014, 04:30 PM
  5. Terraria coming to Windows Phone this Friday with Xbox integration
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 09-10-2014, 01:42 PM
LINK TO POST COPIED TO CLIPBOARD