1. ilumianate920's Avatar
    Hi all, I have a Lumia 920 on EE UK. I have just recently applied the Cyan update. However I am now noticing that the signal is constantly switching between 3G+ and H+.

    When I attempt to use the data the signal will change from 3G to H+. The data will only work though once it has established H+ and there is a considerable delay when it switches until the data becomes available. As a side effect it seems the battery life is being effected quite severely.

    Any information on this would be appreciated! I've attached my version numbers below.

    Thanks
    wp_ss_20140929_0002.png
    09-29-2014 03:07 AM
  2. Muessig's Avatar
    This probably means you're in an area that's bordering on a 3g or a H+ area - this will definitely chew through your battery as your phone can't decide! Go to settings>mobile+sim>sim settings and change your highest connection speed to 3G - this should help out.
    Laura Knotek likes this.
    09-29-2014 01:48 PM
  3. ilumianate920's Avatar
    Thanks for the advice but I've already got it set on 3G as I am not on a 4G contract. Its saying 3G+ not 3G. I understand that 3G is a slower connection than H. After doing a bit of reading I think 3G+ is basically saying H / H+ is available and when I go to use the data it connects to one...?
    09-29-2014 03:46 PM

Similar Threads

  1. Replies: 8
    Last Post: 09-28-2014, 04:43 PM
  2. How do I sync sent emails between WP 8.1 and iCloud?
    By WPCentral Question in forum Ask a Question
    Replies: 0
    Last Post: 09-28-2014, 11:05 AM
  3. Replies: 4
    Last Post: 09-28-2014, 09:04 AM
  4. What is this mini arrow near the wifi / signal strength near the icon?
    By WPCentral Question in forum Ask a Question
    Replies: 6
    Last Post: 09-27-2014, 02:24 PM
  5. Lumia 930 losing network signal
    By Eugenio Di Tullio in forum Ask a Question
    Replies: 0
    Last Post: 09-27-2014, 05:50 AM
LINK TO POST COPIED TO CLIPBOARD