1. RANJAN SENGUPTA1's Avatar
    hi my lumia 520 is about two months old and was running well, few days back the battery got low and phone powered off, i started to charge it but the charging sign would not show up only the 'nokia" screen was there then i opened back lifted the battery replaced it again to resume charging but the problem did not fix and now as i charge it or press the start button it vibrates the "nokia" screen comes then the light blue screen with nothing on it then screen goes blank, when the phone was working there used to b "windows phone " on the blue screen, then came the home screen with tiles, i think it is not booting please do help! i tried to press start and vol down button together but same thing happens. Battery problem is not there the phone is just not starting up. anybody please guide me.
    10-15-2014 12:44 PM

Similar Threads

  1. Can I fix / salvage my Lumia 810?
    By suharsh in forum Windows Central Archive
    Replies: 6
    Last Post: 11-15-2014, 08:28 AM
  2. Lumia 925,730 or 630?
    By Emzijs in forum General Phone Discussion
    Replies: 4
    Last Post: 10-28-2014, 07:55 PM
  3. Lumia 520 no cyan update
    By azi nuamid in forum Windows Phones
    Replies: 5
    Last Post: 10-16-2014, 02:36 PM
  4. AT&T Lumia 830 to come with Qi wireless charging after all
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 10-15-2014, 11:42 AM
  5. Why are my Lumia 521 Wi-Fi calls getting disconnected after 1:04?
    By ithinkurdumb in forum Windows Central Archive
    Replies: 0
    Last Post: 10-15-2014, 11:06 AM
LINK TO POST COPIED TO CLIPBOARD