Surface Pro 7 deal! Save big at Amazon right now

  1. realwarder's Avatar
    Well some sad news is my 920 appears to have died on me overnight. It was running fine and I plugged it in to charge last night. This morning, nothing.

    I used the soft reset button combo and that caused a vibrate but no screen to come on.

    Today I've left it on wireless charger and plugged in for several hours each, but now it doesn't even vibrate.

    Thankfully I had a 635 floating around and have switched to that, but I'm missing my 920. It's been a great phone and is over two years old now, but still, odd that it just stopped working.

    Anyone got any ideas to revive this?

    Thanks
    02-04-2015 11:38 PM
  2. Laura Knotek's Avatar
    Have you tried the Lumia Software Recovery Tool?
    aximtreo likes this.
    02-05-2015 01:28 AM
  3. realwarder's Avatar
    Have you tried the Lumia Software Recovery Tool?
    Sadly it doesn't respond to USB Laura. I charged overnight again and it now vibrates when power is attached but doesn't respond when plugged in to a PC or power button pressed.

    I am wondering if the battery has finally given up the ghost and it no longer charges. I may try getting a replacement to see if that does anything.
    02-05-2015 08:59 AM
  4. Jazmac's Avatar
    I've never hear of one actually dying before. Here I am thinking the 920 is virtually indestructible. My 900 still boots up. Heck my HTC Arrive boots up. (yes, you never forget your first) :) Sad news OP. Use a different charging cable and see if that helps.
    02-05-2015 09:11 AM
  5. NutmegState's Avatar
    Take apart the phone to the point where you unplug the battery (plenty of YouTube videos). Reseat everything and reassemble the phone. The phone may actually turn on while you are in mid-assembly. I have had this happen before. Not sure if it is a faulty power button or something else but it seems to work. I love the 920, but it has some flaky hardware issues. This could be an issue with the USB port itself a weak point on this phone even if you wireless charge which I do. Whatever the cause, it is probably not dead. You may still need to use the recovery tool
    02-05-2015 11:12 AM
  6. UntamoUnikameli's Avatar
    You may want to try soft reset :) Press and hold the power button and volume down button for about 10 seconds
    My lumia 920 does that randomly :/
    Last edited by UntamoUnikameli; 02-05-2015 at 11:55 AM. Reason: Typo
    02-05-2015 11:55 AM
  7. UntamoUnikameli's Avatar
    if that dosnt work try hard reset. That will delete all of your files from phone and reset it to factory settings .
    02-05-2015 11:57 AM
  8. Timbre70's Avatar
    Sounds like screen is fried.
    02-05-2015 06:42 PM
  9. raycpl's Avatar
    It happens a few times in my 920. I had location service & wifi on while juicing up overnight on my wireless charger. Next morning it was dead.
    Battery was fully discharged. However it did become alive again when I charge it on a AC-15...
    Don't give up hope
    02-05-2015 07:58 PM
  10. gordonfink's Avatar
    Since it vibrates when you plug it in, it's not the charging port.

    Sounds to me like it doesn't have enough juice to run on, which is what happens when the battery dies. It vibrates, and does nothing. On some models, the Windows key will flash for awhile until it turns on.

    Sounds to me like maybe the battery bit it.
    Laura Knotek likes this.
    02-05-2015 08:10 PM
  11. raycpl's Avatar
    Oh... BTW.. Make sure your USB cable itself is working. Some generic cables are crap - the connecting points are dodgy. It might make your phone vibrate but it wont charge... I know cos I had one before
    02-05-2015 09:59 PM
  12. realwarder's Avatar
    I took the battery out and voltage was 2.5V which is below the lower levels of Lithium ion and into an area where chargers don't charge and think the battery is dead. Since I have a engineering degree and bench power supply I manually charged the battery partially to 3.7V to see if that would revive it. Not totally. It now is more consistent:

    Unit now responds on USB when I use the Power-volume soft reset and Windows sees a Qualcomm HID device but for some reason Nokia Recovery tool doesn't connect. Think I'll try it on another PC later as I'd expect it to then see the phone and reprogram the flash.

    Odd all this happened though.

    Thanks for the suggestions, would be good to get this running again although 635 proving to be better than expected in the meantime.
    raycpl and Laura Knotek like this.
    02-06-2015 07:43 AM
  13. scumdogmillionaire's Avatar
    Mine did this tonight. Pretty much the same symptoms.

    I had it charging (PC USB), unplugged it and Glance screen was just frozen. Did a soft reset, got the Nokia logo then just black. Soft/hard resets will make it vibrate but won't do anything. I have it charging on a Qi charging stand now, the light is on, but the phone just seems dead :(

    I ordered an 830, but I really didn't want to. Was waiting for new flagship. Worst possible time to die.

    Edit: I tried to put my wife's 920 battery in mine to test the battery theory. That didn't pan out. There are files I would like to get off of it that weren't backed up to OneDrive, but I'll live.
    Last edited by scumdogmillionaire; 02-27-2015 at 09:17 AM.
    02-25-2015 09:36 PM

Similar Threads

  1. Why isn't my phone connecting automatically to my home wifi?
    By PerhapsSamson in forum Other Operating Systems
    Replies: 9
    Last Post: 02-05-2015, 09:23 AM
  2. Replies: 1
    Last Post: 02-05-2015, 08:51 AM
  3. Why won't my Nokia Lumia 925 charge?
    By CookieConnoisseur in forum Windows Phones
    Replies: 3
    Last Post: 02-05-2015, 02:52 AM
  4. lumia camera on windows technical preview
    By rory753 in forum Windows Insider Program
    Replies: 0
    Last Post: 02-04-2015, 11:14 PM
LINK TO POST COPIED TO CLIPBOARD