1. Windows Central Question's Avatar
    Hello everyone.

    I brought lumia 635 for T mobile and am using lycamobile sim which is a mvno of T moble as far i have no issues with service I get LTE. But the problem is the phone can't connect to internet I tried few of thing.
    -Here is what I tried:

    --Adding manual APN.
    --Insatlling the Developer preview
    --installing access point (it's not working on this device)

    Plz Help;
    /Thank you
    Omar9399 likes this.
    03-16-2015 02:09 AM
  2. Omar9399's Avatar
    I have the same issue..
    03-16-2015 02:36 AM
  3. RumoredNow's Avatar
    Hello everyone.

    I brought lumia 635 for T mobile and am using lycamobile sim which is a mvno of T moble as far i have no issues with service I get LTE. But the problem is the phone can't connect to internet I tried few of thing.
    -Here is what I tried:

    --Adding manual APN.
    --Insatlling the Developer preview
    --installing access point (it's not working on this device)

    Plz Help;
    /Thank you
    If the device lights up LTE in the notification bar at the top of the screen... Then you do have data connection. Your requests are not getting answered. Also you say you have checked that the APN is correct.

    Sometimes on brand new activations it may take awhile for all your account access to be put in place carrier side.

    I'd check back with lycamobile support.
    Guytronic likes this.
    03-16-2015 03:38 PM

Similar Threads

  1. Windows 10 on Lumia 635
    By bulls96 in forum Windows Phones
    Replies: 6
    Last Post: 03-17-2015, 10:50 AM
  2. Replies: 2
    Last Post: 03-16-2015, 01:47 AM
  3. Windows 10 hang and vibration issue
    By pritam jape in forum Windows Insider Program
    Replies: 1
    Last Post: 03-16-2015, 01:44 AM
  4. Tesco Mobile starts selling the Lumia 435 in Ireland for 80
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 03-16-2015, 01:20 AM
  5. How do I connect my Nokia Lumia 900 to my PC?
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 03-16-2015, 12:30 AM
LINK TO POST COPIED TO CLIPBOARD