1. trevywankenobi's Avatar
    I bought a Lumia 1520.3 from B&H and I cut my sim card down from a micro sim to a nano sim. I know it still works because I put it back in my 920. It says on my 1520.3 says no service in the live tile.
    03-28-2015 12:59 PM
  2. several potatos's Avatar
    If you swapped the SIM in or out of the 1520 while it was on, that may be your issue. That, and cut SIM cards don't work well in general. The adapter you're using to put it in the 920 may be why it works in it. Try getting a real nano
    03-28-2015 01:27 PM
  3. r970617's Avatar
    Did the nano sim resolve the issue? I just got a 1520 that can't connect to a network. I have a nano sim and I checked it in another phone and it is working.
    12-13-2016 09:45 PM
  4. NookHD's Avatar
    Last time something like this happened to me. My carrier was T-Mobile. I took it in; they did nothing special just switched the SIM card, and they fixed the problem.
    12-14-2016 04:32 AM

Similar Threads

  1. Lumia Camera 5 (Denim) color problem
    By teohabunal in forum Windows Phones
    Replies: 4
    Last Post: 04-23-2015, 12:28 AM
  2. Replies: 4
    Last Post: 03-29-2015, 06:38 AM
  3. No Keyboard in iPhone?
    By FiveFngrsOfDef in forum Connected Living
    Replies: 3
    Last Post: 03-28-2015, 03:28 PM
  4. Photos taken with Lumia 930 beat iPhone 6 Plus and Galaxy Note 4 in blind test
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 03-28-2015, 12:11 PM
  5. Is there a virus guard for the Microsoft Lumia 535?
    By WPCentral Question in forum Windows Phones
    Replies: 5
    Last Post: 03-28-2015, 12:05 PM
LINK TO POST COPIED TO CLIPBOARD