1. Windows Central Question's Avatar
    My phone was working just fine then one morning it wouldn't connect to my cellular network and still will not connect please help
    05-17-2015 04:31 PM
  2. Guytronic's Avatar
    A few things to try...

    Re-seat the SIM
    Soft reset (reboot)
    Turn off wi-fi
    Laura Knotek likes this.
    05-17-2015 05:24 PM
  3. Deepak's Avatar
    Same problem here with my 830. The SIM card is detected but there's no service. Sometimes it connects but after a few hours it's again "no service".

    I'm getting a new SIM because my current one was cut to a nano SIM from micro, may be with error.

    Any chances of yours being the same problem?
    Guytronic likes this.
    05-17-2015 05:47 PM
  4. nohra's Avatar
    A few things to try...

    Re-seat the SIM
    Soft reset (reboot)
    Turn off wi-fi
    Any other suggestions? I tried these and no luck. Mine just started the SIM card error message today. No new network or carrier, same phone/card I've had for over 2 years. In fact the first time I've ever taken the SIM card out was today in trying to 're-seat' it as described above.
    09-07-2015 03:19 PM

Similar Threads

  1. Finding a Lumia 930 in the US
    By EMitchell in forum Windows Phones
    Replies: 12
    Last Post: 06-17-2015, 11:40 PM
  2. How can I get my Lumia 535 Internal Ringtones?
    By Rita Lincolnshire in forum Windows Phones
    Replies: 9
    Last Post: 05-20-2015, 07:32 AM
  3. Why am I unable to connect to the internet?
    By Pilgrim1936 in forum Windows 10
    Replies: 0
    Last Post: 05-17-2015, 04:24 PM
  4. W10 TP reverts back to Cyan
    By shaunydub in forum Windows Insider Program
    Replies: 9
    Last Post: 05-17-2015, 04:09 PM
  5. Replies: 2
    Last Post: 05-17-2015, 03:22 PM
LINK TO POST COPIED TO CLIPBOARD