1. Windows Central Question's Avatar
    Hi,

    Installed the latest build on my Lumia 920. Despite lots of app crashes and bugs I was very satisfied. This morning my phone crashed while hosting a wireless hotspot. I haven't been able to get it running since. It just starts, show Nokia and the screen turns off after few secs. Sometimes it does this in a loop of 20 or so times and then turns off again. Tried both soft reset for 20 or so times and few hard resets also.

    Anyone had the same? Any ideas.

    Because it looks like Windows 10 bricked my phone :D Been using Windows 10 on my desktop since the day it came out with no problems.
    05-23-2015 04:04 AM
  2. ven07's Avatar
    Did you try using the Windows Phone Recovery Tool? or even the Lumia Recovery Tool..

    Give that a go and report back :)
  3. ven07's Avatar
    Did you try using the Windows Phone Recovery Tool? or even the Lumia Recovery Tool..

    Give that a go and report back :)
    RumoredNow likes this.
    05-23-2015 08:59 AM

Similar Threads

  1. Replies: 8
    Last Post: 09-19-2015, 03:01 PM
  2. No USB after build 10080 on Nokia Lumia 1320
    By Sunstorming in forum Windows Insider Program
    Replies: 1
    Last Post: 06-20-2015, 11:43 AM
  3. Strange Request - How do I Make Sure I STAY on WP 8?
    By jefbeard911 in forum Windows Phones
    Replies: 4
    Last Post: 06-12-2015, 12:33 AM
  4. What could be the reason that the touchscreen quit working on my Surface RT?
    By Windows Central Question in forum Microsoft Surface Laptop
    Replies: 0
    Last Post: 05-22-2015, 11:50 PM
  5. Replies: 0
    Last Post: 05-22-2015, 10:14 PM
LINK TO POST COPIED TO CLIPBOARD