1. Russ Bilbey's Avatar
    Since the latest windows 10 preview update, I have 2 entries for 'PHONE' in my main apps menu (under 'P') and I can't make any calls. One of the entries does nothing but cannot be deleted, the other entry tries to open up but then closes after about a second. This means I can't make any calls (although it receives calls OK). The phone is also getting crazy hot and batter only lasts about 2 hours and the battery saver app won't run either.
    06-23-2015 03:01 AM
  2. Harrie-S's Avatar
    I guess a hard reset is needed or rolling back to 8.1 (and try again).
    But with TP you never know so no guarantee on success with above methods.
    But draining in 2 hours is not "normal" for this TP build. Actual the battery "drain" should be about the same as on 8.1 (for my 920 and 930 this is the case)

    Good luck
    06-23-2015 03:13 AM
  3. pureview_lvr's Avatar
    If you facing more problems then I think you should roll back to WP 8.1..and windows 10 is still technical preview and bugs and errors are possible there... But it should not be easy..
    06-23-2015 03:32 AM

Similar Threads

  1. Replies: 7
    Last Post: 01-13-2016, 09:27 PM
  2. Why isn't my phone connecting to a particular wifi network?
    By ronston kevin in forum Other Operating Systems
    Replies: 6
    Last Post: 06-26-2015, 01:51 AM
  3. Replies: 1
    Last Post: 06-24-2015, 11:55 PM
  4. Windows-powered basic & smart-ized basic phones
    By asyl15 in forum General Phone Discussion
    Replies: 0
    Last Post: 06-23-2015, 12:13 AM
  5. Widows Phone App developer
    By gemini5150 in forum App Spotlight
    Replies: 0
    Last Post: 06-22-2015, 08:28 PM
LINK TO POST COPIED TO CLIPBOARD