1. CaptainLumia's Avatar
    I have an issue I cannot seem to trouble shoot. I 'should' be able to get full '4G LTE' download speeds with my carrier, but I can't get anything above 17 Mbps DOWNLOADS, but they are usually closer to 4 or 5. Oddly, my upload speeds are almost always faster. Anyone have any clue what's causing this?
    06-26-2015 06:24 PM
  2. cane prevost1's Avatar
    Do you have the correct version of the phone? It comes in different versions with different cell bands. What's your carrier and what version of the phone do you have?
    06-26-2015 10:36 PM
  3. CaptainLumia's Avatar
    I have the RM-1096 which is the 'dual sim lte' model. After further testing, I've come to the conclusion that both my wireless carriers just have awful service in my area (AT&T and T-Tmobile). I pulled both sims and tested in my 520, the speeds were significantly lower. I was able to get around 20+ Mbps on my 640, but on the 520, in the same area, it capped around 6 or 7.

    The reason I get 4 or 5 on my 640 at work is because I work in an area with a lot of interference I guess. My 640 identifies the network (using the app 'Net Check') as LTE on my 640, but not the on the 520.

    At the end of the day, I could care less about the speeds, I just want to make sure I'm able to get as much connectivity as possible, since I'm often in remote areas.

    I'm mildly surprised I can't exceed 20 Mbps with either carrier, as I'm located in Southern California in a major metropolitan area, but it is what it is.
    06-29-2015 11:31 AM
  4. LouCap's Avatar
    I've found the same to be true. Depending on where I am in my local area I can get blazing fast speeds, or just limp along. My 640 XL gets speeds comparable to every other LTE phone I've had over the last two years, so I don't think it's anything to be worried about.
    CaptainLumia likes this.
    06-30-2015 09:55 AM
  5. tedj101's Avatar
    I am having similar results. At my house, my speeds are disappointing. On the road, they vary all over the place. I have the 640XL on T-Mobile. I also have 4 phones on AT&T, 2 Galaxy S4's, a Note 3 and a Blackberry Z-10. All of them except the Blackberry get similar speeds except that the 640XL on T-Mobile gets significantly better speeds indoors than any of my AT&T phones. I think this is because they are using Band 12 around here (700mhz) and it is better at penetrating cover.

    Regards,
    <TED>
    07-03-2015 03:01 PM

Similar Threads

  1. Replies: 5
    Last Post: 06-29-2015, 11:43 AM
  2. How do I move from Slow Ring to Fast Ring on my Phone?
    By cwmcgowen in forum Windows Insider Program
    Replies: 4
    Last Post: 06-26-2015, 11:51 PM
  3. System Apps not Opening on 10149
    By nkaufmann in forum Windows Insider Program
    Replies: 4
    Last Post: 06-26-2015, 07:40 PM
  4. Replies: 1
    Last Post: 06-26-2015, 05:28 PM
  5. Information on W10 language deployment
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 06-26-2015, 05:12 PM
LINK TO POST COPIED TO CLIPBOARD