1. Windows Central Question's Avatar
    I picked up a new Lumia 640 for T-Mobile, inserted my already active T-Mobile SIM and powered it on. It asked a few questions and eventually wanted the wifi password in my home. After a little while I noticed it was just sitting there, unresponsive to touch. I then noticed it was in a reboot loop every couple minutes. I waited a while, thinking what a silly initial software update it had but then after like 15 minutes decided all was not well. After a few cycles of pulling the battery, I concluded something very bad happens on every boot. I tried turning off Wifi calling, it didn't help.

    A little research suggest it was an interaction between my Netgear R7000 router (latest firmware) and the phone, so I changed the Wifi SSID and let the phone boot again. This time it did not crash I had it connect to the Wifi hotspot on my Android phone, which worked fine with no crashes.

    My particular Netgear R7000 is configured to only be an access point, with a more serious router/firewall to the Internet. I didn't see any Wifi settings that seemed especially odd, WPA2-AES security was set.

    Just as a final test, I assured Wifi calling was off, rebooted, entered Wifi settings, picked my home WiFi hotspot, entered the password, the busy flow of dots at the top started, after a few seconds, the flow of dots froze, the phone is now totally unresponsive. I wait a couple minutes, and it reboots, and didn't remember my WiFI password, so is not locked up.

    Unless someone has a suggestion on what to change in my Wifi settings, or has a software update for the 640, the phone will need to be returned. A phone that doesn't work with my home Wifi is pretty much unusable. I have lots of other devices that use Wifi, and this is the first with a problem.
    07-25-2015 11:50 PM
  2. Compusmurf's Avatar
    Hmmm. Not sure. My buddy has a 640 and I have a 640xl both have been on my router (same one as yours) and haven't had any issues.
    08-09-2015 11:32 PM
  3. TechAbstract's Avatar
    Read the reviews on Amazon. Especially the first helpful one. I have the same router. Haven't even upgraded the firmware since I first got it two weeks ago. Looking for a stable firmware and stick with it. The firmware I am using is V1.0.4.18_1.1.52. Seems reliable for me. I suggest you try a different firmware than the one you are using.

    Amazon.com: NETGEAR Nighthawk AC1900 Dual Band Wi-Fi Gigabit Router (R7000): Computers & Accessories
    aximtreo likes this.
    08-14-2015 02:34 AM

Similar Threads

  1. need help installing the rtm iso to my laptop
    By miguel11691 in forum Windows 10
    Replies: 11
    Last Post: 07-26-2015, 09:51 PM
  2. Will buying this rapid charger hurt my Lumia 640?
    By miguel11691 in forum Windows Phones
    Replies: 1
    Last Post: 07-26-2015, 11:49 AM
  3. Double tap Navigation bar on WM10 to lock the screen
    By sunbee in forum Ask a Question
    Replies: 2
    Last Post: 07-26-2015, 07:43 AM
  4. Why am I not able to create a new MS Dev account?
    By namy_grooves in forum General Phone Discussion
    Replies: 0
    Last Post: 07-25-2015, 11:33 PM
  5. Replies: 2
    Last Post: 07-25-2015, 10:52 PM
LINK TO POST COPIED TO CLIPBOARD