1. Vladimir Ka's Avatar
    I think this is a new issue, never noticed it before.

    I set 3 alarms (just in case), 6:00, 6:15, 6:30.
    First alarm went off, I pressed dismiss and went back to sleep.
    Did not hear any other alarms go off.
    Woke up at 6:33 by myself.. Alarm was not ringing, as soon as I unlocked the phone, 6:30 alarm went off and started ringing.
    But that only happened after I woke up the phone with the power button....

    I'll try to delete and make new ones.. weird..
    gpobernardo likes this.
    02-02-2016 03:04 PM
  2. anon(5326758)'s Avatar
    What build are you on?
    I have seen similar things on .29 - use Hey Cortana to send a text - goes thru all the motions except pauses at "Message Sent," but doesn't actually send until you swipe to unlock. Another time I wasn't getting SMS notifications, and yet another time it happened when I tried to change the song playing (using the skip forward button on the music drop-down). It's like every once in a while the phone says "hey I can't do this because the screen is locked," even though the operations usually work under lock screen. Unlocking always clears it up. This was all on build .29. I'm hoping .71 fixes this but since it doesn't happen often (maybe once a week?) I have to give it time to see.
    02-02-2016 05:20 PM
  3. enthuz's Avatar
    I just experienced the alarm issue this morning. I'm running the latest build on a 1520.
    02-02-2016 05:26 PM
  4. anon(5326758)'s Avatar
    ok, on build .71 I just missed a reminder. It should have happened at 5:25, but I took my phone out of my pocket around 5:30 and when I powered it on the reminder flashed as soon as the screen came on.
    02-02-2016 08:50 PM
  5. jblanken64's Avatar
    Same here. I've seen a post elsewhere about alarms not firing during quiet hours. I'm on the latest build (.71 on 950XL) and this is new behavior.
    02-03-2016 06:52 AM
  6. seldzar's Avatar
    I didn't have issues with my alarm before the update, I now have had 2 days in a row where it didn't go off. Or, it went off when i unlocked the screen.

    I've got quiet hours ending 15 min after my alarm. This which worked fine before to address the "all notifications you received overnight will go off when quiet hours ends"

    I've changed my ending quiet hours to 2 min before my alarm and i'll see how that goes.
    02-03-2016 07:42 AM
  7. Krystianpants's Avatar
    I would do a soft reset after deleting alarms. Hold power and down volume till it resets. Then re-add. I had issue with hey Cortana not working. Had to do that and relearn voice. But alarms are working after I did that process. Granted never tested them before. But I know there's reliability issues with alarms after updates sometimes. You will have to login to ms account after reset. At least I had to under accounts.
    02-03-2016 08:09 AM
  8. omagic82's Avatar
    Same issue here. I'm on the latest build on the 950. Two days straight that alarms aren't going off. I did a few tests and as soon as I unlock the phone the alarm sounds.
    02-03-2016 09:02 AM
  9. Cerberus1953's Avatar
    I had the same problem yesterday morning in that my alarm didn't go of. I'd installed .71 the night before.

    I had a play last night after reading this thread. I got the same, locked and the alarm didn't sound, unlocked it did. I then just powered the phone off and back on again. Did the same test again and the alarm sounded with the phone locked.

    Alarm worked OK this morning.
    02-03-2016 09:23 AM
  10. enthuz's Avatar
    It didn't work for me again. I will try a 3rd party app tonight and report back.
    02-03-2016 07:27 PM
  11. sahib lopez's Avatar
    Same here on my 830. Alarms did not go off unless I unlocked my phone .
    02-03-2016 08:37 PM
  12. enthuz's Avatar
    Update: 3rd party alarm apps do the same. So it's something with the API or deeper. I left feedback and upvoted the other reports of the same.
    02-04-2016 07:46 AM
  13. seldzar's Avatar
    After changing my quiet hours to end 2 min before my alarm, and rebooting the phone as suggested by Cerberus1953, my alarm worked fine this morning.

    However the moment I dismissed the alarm my notifications went off. It seems if you have quiet hours end BEFORE your alarm you'll receive every notification (w/sound) received during that time as soon as you dismiss the alarm.

    This was the reason I set my quiet hours to 15 min after my alarm. When you do that, you don't receive a barrage of notifications when you dismiss your alarm. I changed my quiet hours back to 10 min after my alarm and I'll see tomorrow if it goes off again (like it used to)
    02-04-2016 10:48 AM
  14. Vladimir Ka's Avatar
    I've never had Quiet Hours setup, so that was not related to me.

    I've removed the old alarms, re-created and rebooted. Seems to be working correctly now.. we'll give a couple of more days to test..
    02-04-2016 12:53 PM
  15. DLong4's Avatar
    L950, OS .71, and I was using my phone this AM, reading email or news at the time, and the alarm didn't go off.
    02-04-2016 04:40 PM
  16. seldzar's Avatar
    My alarm worked fine this morning with quiet hours enabled.

    The solution here was to remove the alarm, reboot and then add the alarm back in.

    It might be even as simple as changing the alarm time and then setting it back but i'm not going to mess with it anymore as it's now working.
    02-05-2016 11:51 AM
  17. enthuz's Avatar
    Is that remove "alarm setting" or "alarm app"? My alarm worked this morning after turning off quiet hours last night.
    02-05-2016 12:31 PM
  18. seldzar's Avatar
    You can't remove the alarm app. I removed the alarm I had setup then put it back in.
    02-05-2016 01:16 PM
  19. enthuz's Avatar
    Okay. Trying that now. Thanks.
    02-05-2016 03:03 PM
  20. freestaterocker's Avatar
    I have had this issue for a couple days with every single new build. The same fixes don't work every time, and I've been seriously considering rolling back to 8.1.1 between this and Cortana now being mostly useless.
    02-14-2016 11:02 AM
  21. Levitator's Avatar
    My alarm won't make a single sound if the 950XL is locked. Got the new FW update a couple of days ago and there was an announcement about clock and alarm having been updated. No effect on the alarm issue. I need the alarm to work and now I have take my old 1020 with me when travelling... Shouldn't be that hard to fix...
    02-19-2016 06:47 AM

Similar Threads

  1. Replies: 5
    Last Post: 02-03-2016, 03:15 PM
  2. Who's going to Microsoft Ignite?
    By Mark Kaplan in forum Microsoft News & Rumors
    Replies: 0
    Last Post: 02-02-2016, 02:46 PM
  3. Display Dock not Recognizing USB-C cord for 950 Windows Phone?
    By Windows Central Question in forum Windows Phones
    Replies: 1
    Last Post: 02-02-2016, 12:57 PM
  4. Windows 10 Phone ROM
    By Juan Rosado Casanova in forum Software Development and Hacking
    Replies: 1
    Last Post: 02-02-2016, 12:54 PM