1. HeikBre's Avatar
    My Lumia 650 (German version) keeps losing the WiFi connection about 3 times a day, sometimes twice in 5 minutes. It has Windows 10586.164 installed. I know that it is not a problem of the router settings: I am using a standard configuration and had it checked with the router manufacturer. Other Lumia devices in the same WiFi network do not lose the WiFi connection. When the WiFi connection is lost, I have to shutdown the phone, wait for about 1 minute, and restart it. Trying to reconnect the phone in the "Settings" dialogue only leads to an error message.

    But this is only part of a much bigger problem. I can easily reproduce other issues following directly after the loss of the WiFi connection. This is what happens:

    1) The WiFi connection gets lost. I have to restart the phone.

    2) I synchronize pictures on the 650 with my OneDrive account. When I start the "Pictures" app after restarting the phone, I see the pictures I took with the 650, and older pictures that were already on the SD card. When I tap the "Synchronize" button in the "Pictures" app, the button starts circling. After a few seconds, I can watch all the "new" pictures (the ones I took with the 650) disappearing. With about 70 "new" pictures, this takes a few seconds, and I can watch the shown number of pictures taken at a certain date being counted down to zero. The "old" pictures (the ones taken with my old Lumia) are not being deleted and remain on the SD card.

    3) I also saved a few "new" mp3 files on the SD card in the "Music" folder. All the new files are also gone after synchronizing with OneDrive.

    4) All the "new" and "old" pictures are still available in my OneDrive store. When I copy them back to the SD card of my Lumia, the same happens again after the next loss of the WiFi connection. I already reproduced it about 20 times now.

    5) Sometimes, the WiFi connection gets lost immediately when I start an app. Today it was the "Camera" app causing the loss of the connection, yesterday it was the "Maps" app.

    What I can also say is that the problem is not limited to a certain WiFi network. And: I already changed the Lumia 650 once, but the problem remains exactly the same.

    I use my phone almost entirely for work, and I need a stable and reliable WiFi connection. Also, taken pictures must not get lost: I need them for documentation purposes, and it is extremely important for me that I can show them directly on the phone screen, and that they are available when I need them. So, the described problems are not only a minor flaw for me. I really hope that there will be an update soon fixing the issue.
    Last edited by HeikBre; 03-19-2016 at 11:48 AM.
    03-19-2016 06:28 AM
  2. iJohnnyCash's Avatar
    I disagree with the meaning of standard configuration for a wifi network. Is not exist such a thing.

    Try to change the wifi channel (1,2,3...) or the band (2.4ghz or 5ghz) also you may to check if it work better with other wifi protocols, like b or n.
    Also if you use WEP and not WEP2-Personal you have to many reason to change it to the better one.

    If you have in your area to many other wifi networks, you should check what channel has the more less networks and use that.

    Just do some tests ;)
    03-19-2016 03:41 PM
  3. HeikBre's Avatar
    Thank you, iJohnnyCash, for your help!

    I already did a lot of testing and changed WiFi band, channel, and protocol. My encryption is WPA2. Also, I do not use Bluetooth and NFC. All this did not bring any improvements. The behavior of the phone is still the same, and it keeps losing the connection. I also have a Lumia 640 with Windows 10 in the same WiFi network, and a Lumia 620 with Windows 8.1. Both do not have any problems with WiFi. Other WiFi networks around are not close enough to cause any traffic problems.

    I contacted the manufacturer of my router and asked them if they have an idea what to do. They checked all the WiFi settings of my router and approved them. Btw, the same problem also occurs when I use another WiFi network.

    All in all, I am pretty sure that a firmware update for the 650 might be a good idea.
    03-20-2016 05:13 AM
  4. iJohnnyCash's Avatar
    Then, that is very bad.
    Maybe you must contact with Microsoft.

    I have received yet my L650, I hope not to have same issue, cause my router is locked by the network administration and I can't do experiments with the settings.
    03-20-2016 09:55 AM
  5. HeikBre's Avatar
    Good news!

    Yesterday at 7 pm German time, there was a big firmware update available for my 650. Before the update, the WiFi connection of my 650 broke down 3 times yesterday, so it won't take long until I see if the FW-update fixes the WiFi issue.

    Cross your fingers! And good luck for you with your 650!
    03-23-2016 02:10 AM
  6. Mihai Aldea's Avatar
    Unfortunately, I have the same problem with my Lumia 650.
    I am able to re-establish the Wi-Fi connection only after phone restart...
    So far, all the performed tests with router setting configuration failed. Please leave an comment here if you find a solution...
    03-28-2016 02:17 AM
  7. anon(5348929)'s Avatar
    I have a similar problem. When the wifi connection is established, all is fine. But when I leave home and come back, the phone can't reconnect to my wifi unless I reboot. Same with the wifi at my father's.

    //edit: I have the latest firmware update installed with the latest production version of the OS.
    03-28-2016 04:58 AM
  8. chancooluk's Avatar
    I have a similar problem. When the wifi connection is established, all is fine. But when I leave home and come back, the phone can't reconnect to my wifi unless I reboot. Same with the wifi at my father's.

    //edit: I have the latest firmware update installed with the latest production version of the OS.
    This is also an issue on the Lumia 550.

    Please note your firmware version (found in settings, system, about). The latest firmware 01078.00037.16082.410xx includes fixes for WiFi issues on both the Lumia 550 and Lumia 650, however, it hasn't been rolled out to all devices yet.
    03-28-2016 01:06 PM
  9. anon(5348929)'s Avatar
    It's the latest firmware: 01078.00037.16082.41014
    OS build is: 10.0.10586.164
    03-28-2016 02:52 PM
  10. Kunal Dudwadkar's Avatar
    So I'm not alone on this one. I have the same issue. Wifi loses connection and then only a reboot can make it connect. Does not connect automatically when I reach home or office. again a reboot is required.

    OS Build- 10.0.10586.218
    FW- 01078.00037.16082.41055
    04-23-2016 08:57 AM
  11. Have Heart's Avatar
    I don't have any problems yet with Wi-Fi.

    OS build: 10.0.10586.218
    Firmware: 01078.00037.16082.41006
    04-23-2016 12:54 PM
  12. Colenbrander's Avatar
    My WiFi seems to be relatively troublefree after switching off location.
    04-26-2016 04:13 PM

Similar Threads

  1. Lumia 640 charging problems
    By GoClever user in forum Windows 10
    Replies: 3
    Last Post: 03-26-2016, 06:43 PM
  2. Developers Features.. What is Use of this function ?
    By ErJaspreetSingh in forum Windows 10
    Replies: 2
    Last Post: 03-19-2016, 10:40 AM
  3. Almost all of my items under Menu on My Windows 535 Lumia phone won't open, why?
    By Windows Central Question in forum Windows Phones
    Replies: 1
    Last Post: 03-19-2016, 07:11 AM
  4. Cannot update my Lumia 830 to OS version 8.10.15148.160?
    By Windows Central Question in forum Windows Phones
    Replies: 1
    Last Post: 03-19-2016, 05:29 AM
  5. OneDrive pics keep showing on my Lumia images in the gallery, why?
    By Windows Central Question in forum OneDrive
    Replies: 1
    Last Post: 03-19-2016, 04:35 AM
LINK TO POST COPIED TO CLIPBOARD