1. Windows Central Question's Avatar
    I have a Lumia 640. While my wifi in the past has been sluggish and occassionally drops, today it seems to have a problem not connecting rather than connecting.

    Most of the time I can't get the device to surf. I tried rebooting the device but that didn't help.

    I tried my cell data and it works fine. I tried other devices on the wifi signal and they are fine.

    I have wifi sense, bluetooth, battery saver all turned off. The wifi indiccator shows I am connected to wifit and the little arrow is constantly appearing.

    I'm not a technical person so I don't know what other information you need.

    Any ideas?
    04-09-2016 06:41 PM
  2. realwarder's Avatar
    When you have Wi-Fi issues with any device it is always worth checking the firmware on your Wi-Fi access point (i.e. Wi-Fi router). I suggest you check that for upgrades and see upgrading that helps.
    Laura Knotek likes this.
    04-09-2016 08:04 PM
  3. thron's Avatar
    Are you on the Redstone build of windows 10? If so, a lot of similar issues relating to wifi and that build. As realwarder mentioned, checking your router may prove helpful, update firmware and try different DNS; it's possible your isp's DNS servers are hiccupping.
    04-09-2016 08:23 PM

Similar Threads

  1. Why can't I select Wifi channel 13 as with Windows7?
    By Windows Central Question in forum Other Operating Systems
    Replies: 1
    Last Post: 04-09-2016, 01:48 PM
  2. Lumia kills wifi for all devices
    By magicdesign in forum Windows 10
    Replies: 3
    Last Post: 04-09-2016, 12:16 PM
  3. Replies: 1
    Last Post: 04-09-2016, 01:45 AM
  4. Anyone suggest a fix: 640 losing WIFI connection
    By stocktiki in forum Windows Phones
    Replies: 0
    Last Post: 04-08-2016, 10:56 AM
  5. Why cam I unable to connect to wifi?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 04-08-2016, 07:45 AM
LINK TO POST COPIED TO CLIPBOARD