Surface Pro 7 deal! Save big at Amazon right now

  1. WPWeasel's Avatar
    So I got tired of waiting for T-Mobile to release their Windows 10 image and decided to upgrade to Windows 10 yesterday. Fast forward past two updates and now I'm on build 10.0.14393.351. Unfortunately, it seems like the upgrade nobbled my cell service. I can see I'm connected to T-Mobile LTE service from the notification area, but I don't think I'm getting any response back from the local tower.

    Things are fine connected to WIFI, but I can't send text messages, browse the web using cell data, etc, until I get this issue sorted out. Anyone have any ideas how to troubleshoot it further?

    EDIT: Basic call functionality is available, but nothing data related. I've also noticed that under the SIM Settings that 'IMS Registration' is enabled, but the IMS Status is showing as 'Unregistered'. I'm guessing that's something to do with my issue.

    EDIT 2: Problem resolved. I decided to try and fire up the T-Mobile app on the phone to see if that would make a difference. Oddly enough, it actually did and my IMS status is now set to Registered, with an IMS Identity and IMS Domain set as well
    Last edited by WPWeasel; 10-22-2016 at 10:42 PM. Reason: Clarified issue
    libra89 and Guytronic like this.
    10-22-2016 12:31 PM
  2. Guytronic's Avatar
    Sounds like 10 changed your APN settings.

    If I'm not mistaken IMS is an old multimedia protocol that was never implemented by GSM carriers so that won't be the problem.

    It's probably best to look for working T-Mobile APN settings that function under WM10 and enter those.
    Laura Knotek and libra89 like this.
    10-22-2016 03:08 PM
  3. libra89's Avatar
    Thank you for sharing how you fixed it, also glad that you fixed it too!

    Sent from mTalk
    Guytronic likes this.
    10-22-2016 04:59 PM
  4. WPWeasel's Avatar
    Sounds like 10 changed your APN settings.

    If I'm not mistaken IMS is an old multimedia protocol that was never implemented by GSM carriers so that won't be the problem.

    It's probably best to look for working T-Mobile APN settings that function under WM10 and enter those.
    Actually, if you look on the SIM settings page for the IMS service section it states that "when turned off, you won't be able to text, video call or call over 4G LTE". Which essentially describes the issue I was having. The link below describes it in some more detail.

    https://support.t-mobile.com/thread/...art=0&tstart=0
    Last edited by WPWeasel; 10-22-2016 at 07:05 PM.
    Guytronic and libra89 like this.
    10-22-2016 06:49 PM
  5. boonesmi's Avatar
    oops
    10-22-2016 11:41 PM
  6. boonesmi's Avatar
    Sounds like 10 changed your APN settings.

    If I'm not mistaken IMS is an old multimedia protocol that was never implemented by GSM carriers so that won't be the problem.

    It's probably best to look for working T-Mobile APN settings that function under WM10 and enter those.
    im pretty sure ims registration is required before volte or wifi calling will work
    10-22-2016 11:41 PM
  7. AbeC4's Avatar
    Hi, thanks for the message and just curious your experience with the Win 10 upgrade on the Lumia 640 and how you are liking it? Did you update through the Windows Insider Program? And have you lost any functionality like wifi calling, use of the camera, memory issues? that sort of stuff. Any info would be of much help.

    Thanks and I too am tired of waiting for T-Mobile to upgrade.
    12-13-2016 10:03 AM
  8. jazman_777's Avatar
    I like the upgrade, I only had to add an MMS APN to get MMS working.

    I don't have wifi calling. To get VoLTE working I find that my IMS is unregistered, and running the T-Mobile app (the new one with lots of magenta) always gets me registered, then VoLTE works.
    libra89 likes this.
    12-13-2016 11:35 PM
  9. jcatx03's Avatar
    Originally posted by AbeC4
    Hi, thanks for the message and just curious your experience with the Win 10 upgrade on the Lumia 640 and how you are liking it? Did you update through the Windows Insider Program? And have you lost any functionality like wifi calling, use of the camera, memory issues? that sort of stuff. Any info would be of much help.

    Thanks and I too am tired of waiting for T-Mobile to upgrade.
    W10 works great on the L640. I upgraded via Insider program. Only thing I lost (on T-Mobile) was wifi calling, everything else works.
    12-14-2016 05:12 PM

Similar Threads

  1. Oh Lumia 950 how I missed you
    By mattdodwell in forum Windows Phones
    Replies: 69
    Last Post: 11-11-2016, 01:05 AM
  2. update to widows 10 now no audio alert on Outlook
    By Richard Millichamp in forum Windows Phones
    Replies: 6
    Last Post: 10-24-2016, 01:35 AM
  3. Windows 10 update deleted my files in windows.old
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 10-23-2016, 08:39 AM
  4. update my windows 10 Like anniversary updates
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 10-22-2016, 07:51 PM
  5. Windows 8.1 -- How do I remove properties displayed in the Details Pane?
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 10-22-2016, 10:37 AM
LINK TO POST COPIED TO CLIPBOARD