1. NXTwoThou's Avatar
    This morning I got the Microsoft WPD 5.2.5326.4762 update. Thinking nothing of it, I connected my phone to download pictures a few minutes ago(like I do a few times a week for work) and was shocked to see it pop up saying there's a problem with the device. When I get into device manager and try and update the driver, it says "MTP Device" "A service installation section in this INF is invalid". I connected my phone to a different machine here and it worked fine(that machine hasn't gotten the WPD update yet)

    Anyone come across this before and know of a fix besides uninstalling WPD 5.2.5326.4762 update?
    03-08-2017 12:40 PM
  2. NXTwoThou's Avatar
    After a little research, in device manager, I right clicked, went to Update Driver, Browse my computer for driver software, Let me pick from a list of available drivers on my computer, and selected one of the two "MTP USB Device" rather than "MTP Device". That got me back up and running. If I do "Update Driver" it picks the "MTP Device" again, which fails with "A service installation section in this INF is invalid"
    03-08-2017 12:51 PM
  3. nate0's Avatar
    I just posted about this driver update. Have not installed it yet though. Still researching. It does not automatically install which I guess is due to it being a driver update.
    03-08-2017 01:20 PM
  4. Douglas Poll's Avatar
    Thank you so much, this has solved the problem that I have had since the update today, only interesting thing to note for me is that the icon used to show a small image of the actual phone connected (950xl) in explorer in windows 10 now it is a outline drawing. Although the install of today's update was successful having connected the phone and had the issue i tried to check for updates and windows tried to download and install again but this caused an error message and 'history' now shows a failed install after the successfull one.

    Just happy to be able to connect again.

    Once again many many thanks.
    03-08-2017 02:17 PM
  5. NXTwoThou's Avatar
    FYI, I updated to build 15055 a few minutes ago and when I plugged my phone back in, went back to being "MTP Device" rather than "MTP USB Device". Did the same steps as above and back up and running.
    03-10-2017 03:11 PM
  6. Douglas Poll's Avatar
    Microsoft have finally admitted they made a mistake

    Just seen this on another forum

    One needs to complete part two to stop any re-installing of the wrong driver

    Method 2: Roll back the device driver and remove from system
    Part 1: Roll back the driver (When finished, you must complete Part 2 or the incorrect driver will reinstall)
    Press Windows Key + X and then choose Device Manager in the menu.
    Look for the device with a yellow and red mark next to it. It should be your phone or other connected device.
    Press-and-hold or right-click on the device and choose Update Driver Software.
    You may need to reboot and reconnect the device. If so, follow these steps again to get back to the driver update.
    Select Browse my computer for driver software.
    Choose Let me pick from a list of available drivers on my computer.
    Check Show compatible hardware, select MTP USB Device, and then choose Next.
    Finish the install and reboot your PC. Verify that the mobile device is detected.

    Part 2: Prevent the driver from reinstalling
    Press Windows Key + X, and in the menu click on Command Prompt (Admin), and then choose Yes on the prompt.
    Type pnputil.exe -e and hit Enter. This will list installed device drivers.
    Scroll through the list looking for the description that matches the one in the below example (except for the .inf file’s published name). Make a note of the .inf file name associated. It should be something like oem##.inf with a one or two digit number after the oem in the name, and have the Driver date and version as shown in the following example:
    Published name : oem42.inf
    Driver package provider : Microsoft
    Class : Portable Devices
    Driver date and version : 02/22/2016 5.2.5326.4762
    Signer name : Microsoft Windows Hardware Compatibility Publisher
    4. Now type pnputil.exe -d oem##.inf where the ## is the number in the file name noted below. Example: oem62.inf.
    5. Hit Enter and the incorrect driver is now deleted from your system. When you disconnect and reconnect your device, it should not reinstall the incorrect driver.
    nate0 likes this.
    03-11-2017 03:27 AM
  7. Iulian-Mihail Pipas's Avatar
    works for me too
    03-16-2017 04:26 PM
  8. NathanParker's Avatar

    Thank you Douglass Poll,

    problem solved!
    03-16-2017 07:34 PM

Similar Threads

  1. Microsoft - WPD - 5.2.5326.4762
    By Nate W in forum Windows 10
    Replies: 11
    Last Post: 03-12-2017, 04:34 AM
  2. Is there going to be a Windows 11?
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 03-08-2017, 09:05 PM
  3. My Surface Book Just Took an Update
    By savagelizards in forum Microsoft Surface Book
    Replies: 4
    Last Post: 03-08-2017, 04:03 PM
  4. Why i can't connect to internet using VPN softwares in Windows 10?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 03-08-2017, 01:54 PM
  5. Error 80240020
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 03-08-2017, 12:02 PM