1. WPCentral Question's Avatar
    Hi,

    My lumia 920 was working well 2 weeks back . Now issue is , no network (no signal) where i get only 2G signal. On 3g signal it is working fine. If i select highest speed to 2G .. no network.

    Manual carrier search is showing 2G network, even after selecting it no network

    Reason could be

    1) i am running on 8.1 developer preview and did few updates recently on top of it.
    2) i dropped my mobile 1 week back

    I tried below .

    1) Soft, Hard reset
    2) manual network selection
    3) My mob was running 8.1.. downgraded to 8 using Nokia software suit
    4) I opened my case. all the wire connection looks fine

    Any help would be appreciated. Thanks
    06-25-2014 12:23 PM
  2. moverton's Avatar
    This sounds more like a general network issue. I would suggest contacting your provider and see if they can troubleshoot any issues. They may also want to change your sim card in a worse case scenario.
    06-25-2014 12:35 PM
  3. Venky V's Avatar
    Thanks for your reply . I tested my SIM in other mobiles and 2g is working fine. I tried other carriers in my mob same issue.

    Please help
    07-01-2014 06:53 AM
  4. riteshpande's Avatar
    This is really weird issue, you have tried each and every way... I would recommend you to contact nokia care
    07-01-2014 07:15 AM

Similar Threads

  1. Steam In-home streaming not functional on SP3, Wifi issues
    By fc000 in forum Microsoft Surface Pro 3
    Replies: 9
    Last Post: 08-18-2014, 02:00 PM
  2. Replies: 10
    Last Post: 06-29-2014, 05:18 AM
  3. TD Bank confirms Windows Phone app in the works
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 06-25-2014, 11:11 AM
  4. Nokia Lumia 930 available for pre-order in Belgium and Vietnam
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 06-25-2014, 10:42 AM
  5. App Folder drops Nokia from title and switches to Microsoft in latest update
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 06-25-2014, 10:42 AM
LINK TO POST COPIED TO CLIPBOARD