1. WPCentral Question's Avatar
    After updating for developers win8.1 my , Though i use 2g i am being constantly charged for 3g, I have made sure that there is no problem from the side of the mobile service provider (!dea) chennai, To check that i totally deactivated 3g services to my postpaid number but now i my internet does not work at all.
    that makes me feel win 8.1 supports mostly 3g oly.
    06-28-2014 10:28 AM
  2. Kaushik Banerjee's Avatar
    Settings > cellular+sim > sim settings> set highest connection speed >select 2g
    06-28-2014 10:42 AM

Similar Threads

  1. WTS: Nokia Lumia 1520 - 16GB - AT&T - Black
    By explosive0 in forum Marketplace Archive
    Replies: 17
    Last Post: 07-18-2014, 02:03 AM
  2. Gmail not syncing
    By brienc in forum Ask a Question
    Replies: 7
    Last Post: 07-05-2014, 11:08 AM
  3. HTC should bring quality apps to Windows Phone
    By Anshuman Bhadauria in forum Applications
    Replies: 4
    Last Post: 07-04-2014, 10:01 AM
  4. Alpha Wave, a great time killer game for Windows Phone
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 06-28-2014, 09:42 AM
LINK TO POST COPIED TO CLIPBOARD