• 00Days
  • 00Hours
  • 00Mins
  • 00Secs
Prime Day 2018
  1. WPCentral Question's Avatar
    Now when going to synch I get: To continue using Google on your phone, you'll need to give Windows Phone permission to access your account. When I connect I get a "how does it work" which still does nothing.

    What gives. I "only" use my phone for Google Mail. I am sure there is some 20K plus a year developer that thought this one up.
    07-25-2014 09:38 AM
  2. Beadwindow's Avatar
    PS: Microsoft Account Password and Google Mail password will not take and keeps looping. Did you genuises even check this? I WANT MY GOOGLE MAIL NOW.
    07-25-2014 09:55 AM
  3. centium5000's Avatar
    I had the same problem but found the answer after a day of (mostly frustrating) research...

    As Microsoft insists on using the master Google account password in WP8.1 Cyan setup to do it their official way, there's actually two accounts we need to create on the phone instead of a 'Google Account' if we want to continue using Application-specific / device-specific passwords and bypass this nonsense. The first is for email, the second for contacts & calendar; I used the same device-specific password for both, no need for two separate passwords.

    Email:

    Within Settings -> email+accounts -> add an account -> advanced setup, enter your gmail address and device-specific password , click through to the next screen, then choose 'Internet email'.

    I used the settings in the first attached image (see cyan-email-settings.png).

    Gmail setup is then complete, on to contacts and calendar...

    Contacts and Calendar:

    Within Settings -> email+accounts -> add an account -> iCloud, enter a non-existent account name and a random character or two in the password field. We obviously expect this to fail against the iCloud servers - it's just a placeholder until we edit the advanced settings below.

    After this fails with 'Not up to date', tap through on the iCloud account to the error and then hit close.

    I then changed the settings as per the second attached image cyan-contacts-settings.png.


    All being well you're now set up for Gmail and Google Contacts - your Google Calendar should now be selectable or visible through Settings within WP Calendar as usual.

    Hat Tip to TSStefan for the post 'Cal/CardDav (Owncloud) in WP 8.1' which was invaluable for working out a starting place the above. I can't link to this nor provide text versions of the attached images due to my low post count. Hohum.

    Goodness knows why Microsoft didn't make the CardDAV and CalDAV settings available through account 'advanced setup'. Hey, I'm sure we all like a challenge but maybe not so much when basic functionality disappears and requires hours of forum-trawling to regain!

    Hope this helps someone before their phone hits the wall
    Attached Thumbnails cyan-email-settings.png   cyan-contacts-settings.png  
    08-11-2014 06:46 PM
  4. King Windows's Avatar
    I searched the web for two days out of frustration trying to sync my stupid gmail account because of college and finally found your post. There is no way possible you can know this configuration unless you're a computer wiz?

    It works... Thanks!!!
    09-14-2014 11:50 PM

Similar Threads

  1. Replies: 1
    Last Post: 08-11-2014, 06:58 PM
  2. Microsoft or google services?
    By RavenSword in forum Microsoft News & Rumors
    Replies: 54
    Last Post: 08-11-2014, 10:39 AM
  3. Airplane Mode won't turn off WP 8.1
    By WPCentral Question in forum Ask a Question
    Replies: 6
    Last Post: 07-30-2014, 12:35 PM
  4. Lenovo rival Google Glass...
    By Great deal in forum The "Off Topic" Lounge
    Replies: 0
    Last Post: 07-25-2014, 08:37 AM
  5. Devs of Social, Food or Mail apps have a quick read
    By nosaj_j in forum Developers Corner
    Replies: 0
    Last Post: 07-25-2014, 07:18 AM
LINK TO POST COPIED TO CLIPBOARD