1. AwesomeLewis24's Avatar
    Hello, so recently my Lumia 620 runs extremely slow from time to time. Like after a period of inactivity on the lock screen, when unlocked it will run very slowly up until the point where I will have to do a battery pull to get it to run normal again. As well as that, I've been noticing recently that my Lumia will restart itself randomly. I will be on my laptop for example and out of the corner of my eye I can see the Nokia logo on my screen - indicating that it is turning on. I have tried a soft reset but nothing else as of yet. Any ideas? :)
    08-17-2014 05:32 PM
  2. David P2's Avatar
    I'd check for a dodgy app being installed and get rid. I've had no problems like that on my 620 for the past 18 months.
    08-17-2014 06:00 PM
  3. Bruno Blanes's Avatar
    Got that kind of problem on my Lumia 720, hard reset only thing that worked... Also my recommendation!
    08-17-2014 09:23 PM
  4. ShinraCorp's Avatar
    Hard Reset, or if you like, go Inquisition on it's *** and delete every app until it starts working again :P
    08-17-2014 09:26 PM
  5. thabuff's Avatar
    I'm having the same issue. A hard reset didn't work. any help with this would be appreciated
    08-18-2014 07:54 AM
  6. actionthomas's Avatar
    Same here, this phone is slow as hell and extremely buggy. It has always been since I bought it, whatever WP version or firmware installed.
    I tried hard-resetting, send it back to Nokia (RMA), still slow .
    I really consider changing phone.
    08-18-2014 01:37 PM
  7. AwesomeLewis24's Avatar
    My apps are well.. Official. Not sure if I want to hard reset. Could it possibly be because of the last phone update? I'm gonna wait until the next update and if it still continues after that then I will probably hard reset. Thanks to all the replies above so far ^^^^^
    08-19-2014 12:17 PM
  8. ShinraCorp's Avatar
    Actually I've learned that if you don't have Cyan but 8.1 there is a major performance issue with the 630 so... if you have it, maybe that's why.
    08-19-2014 01:13 PM
  9. AwesomeLewis24's Avatar
    Actually I've learned that if you don't have Cyan but 8.1 there is a major performance issue with the 630 so... if you have it, maybe that's why.
    Nah, I don't have the 630. I mean, at times (especially after a battery pull) the device is fast and runs as normal, but it's only after a period of inactivity whilst locked that it will randomly restart.

    Anyways, my Lumia has downloaded the new update. I'm not getting my hopes up but I do hope that this will sort it out. I'll report back to you guys on whatever happens!
    08-19-2014 02:04 PM
  10. AwesomeLewis24's Avatar
    Just a quick update... Seems like my phone's been running alright as of now - so I would say the update has kinda fixed it. I cant say for sure, but hopefully this has fixed it and I wont get it back down along the line. Thanks for the replies!
    08-21-2014 07:19 AM
  11. Force2Reckon's Avatar
    if your phone has a warranty, you can always ask for replacement from your local store
    08-22-2014 02:31 AM

Similar Threads

  1. Hardware Button Lights remain always on! (Lumia 720 Cyan Firmware)
    By WPCentral Question in forum Ask a Question
    Replies: 11
    Last Post: 08-31-2014, 12:48 PM
  2. Cyan update for lumia 920
    By Jan Ilek1 in forum Ask a Question
    Replies: 4
    Last Post: 08-17-2014, 09:47 PM
  3. Lumia 1020 camera lens
    By Alex Atwi in forum Ask a Question
    Replies: 1
    Last Post: 08-17-2014, 09:33 PM
  4. Nokia Lumia 1320 WP 8.1 but no Cyan
    By WPCentral Question in forum Ask a Question
    Replies: 2
    Last Post: 08-17-2014, 09:08 PM
  5. Lumia after cyan update doesn't read sd card
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 08-17-2014, 07:46 PM
LINK TO POST COPIED TO CLIPBOARD