1. anuradha indika amarasinghe's Avatar
    Hi
    I'm Anuradha. Today I tried to register as a windows phone developer. For that, I went to the https://dev.windows.com/en-us/join and clicked on the button which saying "Accept and Continue" . It took me to the login page and I logged in successfully. After that I was directed to the same registration page (https://dev.windows.com/en-us/join) as earlier. Again I clicked on the button which saying "Accept and Continue" and I was redirected to the same page all the time. So clicked on the dashboard tab this time and clicked on the windows store button. From that I was able to make the 19$ payment and finish the registration. Now when I log in to my account , at the bottom of the dashboard I see an option called "Windows Phone dashboard". When I click on that link again it takes me to the https://dev.windows.com/en-us/join page. I don't know whats going on. I already made the payment and it shows me as an unregistered WP developer. Please help me on this.

    Registration Page
    2.jpg

    Dashboard
    1.jpg

    Thanks
    09-16-2014 11:51 AM
  2. ssapre's Avatar
    Probably better raise a ticket with MS in their forum.
    09-16-2014 01:45 PM
  3. tgp's Avatar
    I did that very thing just today. It went through fine, so I cannot be of any help to you. Sorry! Maybe try a different browser, or try private mode.

    One interesting thing that happened though; I previously had a free developer account through Dreamspark because I had an .edu email. However, it was time to reverify, and that email is no longer valid. This means that I (would have) had to pay the $19.00. However, when I got to the payment page, it said that because of Promotion Code XXXXXXX it was free. I have no idea where the code came from! My personal Microsoft account is linked to my employer's account, so maybe that had something to do with it.
    09-16-2014 02:26 PM

Similar Threads

  1. Replies: 12
    Last Post: 09-25-2014, 10:45 PM
  2. Replies: 17
    Last Post: 09-23-2014, 01:25 PM
  3. Setting up Email issues
    By Christopher Lindsay in forum Ask a Question
    Replies: 2
    Last Post: 09-16-2014, 04:32 PM
  4. any issues with 6tag notifications?
    By Ashish Gupta888 in forum Applications
    Replies: 0
    Last Post: 09-16-2014, 09:50 AM
  5. Forum discussions viewing error on WP Central app
    By Anand PH in forum Ask a Question
    Replies: 3
    Last Post: 09-16-2014, 07:21 AM
LINK TO POST COPIED TO CLIPBOARD