1. Muraziii's Avatar
    Recently, I just got my first WP device, it's Lumia 530.

    So I just went to a problem, twice.
    The first time is when I turned off my phone and when it back on, all apps that I downloaded lost its icons. And when I open it, it shows a never ending loading screen.

    The second time is the same, I turned it back on, and now it just two apps (Facebook and FB Pages Manager) lost its icons and shows a never ending loading screen.

    I uninstalled apps that I think it's suitable to call it corrupted apps, and I tried to reinstall it again. But, Store shows a message box with "We're having trouble installing this app. If this is the first-- ...". I tried many times, didn't change anything. Checked the WP update, mine has the latest version.

    The first solution I got is reset the phone. I tried to format my SD, it didn't change anything.

    I didn't want to reset my phone again, is there any solution for this?
    4Tiles likes this.
    10-24-2014 07:34 AM
  2. dKp1977's Avatar
    After reboot, some of my apps are grayed out too, but this settles within a couple of seconds or at least under a minute. The other thing you're describing is mostly a store issue, which is usually resolved pretty fast.
    10-24-2014 03:21 PM
  3. 4Tiles's Avatar
    I'm having the same problem with a Blu Win Jr. When I install the apps everything works fine, but as soon as I reboot or shutdown the apps on SD card get corrupted exactly as you described. A few of the apps tiles have file location address on their tiles. Several of the apps are also no longer listed in the app list even though they are installed and have tiles on start screen. I have tried 2 different memory cards, one of which has been working fine in a Lumia 520 for a year
    10-28-2014 05:19 AM
  4. Lance_WPCentral's Avatar
    When you normally have apps installed on the SD card, after turning on your phone and when it reaches the main screen the icons and folders take a few seconds to load. However if it detects errors on your SD card, a message pops up asking you if you want to scan your SD card and fix errors and you should select YES. After scanning for a minute or 2, all the tile icons appear back.

    Did you get the SD card scanning option ?
    10-28-2014 06:53 AM
  5. cool8man's Avatar
    Same issue. No error message coming up about the SD card on mine.
    10-28-2014 10:19 AM

Similar Threads

  1. Universal app problems... have to pay twice?
    By sprtfan in forum Windows Phone Apps
    Replies: 2
    Last Post: 10-24-2014, 01:17 AM
  2. All Apps View implementation in Start Menu
    By ReddieTheModernFuturist in forum Windows 10
    Replies: 0
    Last Post: 10-23-2014, 11:09 PM
  3. View is a beautiful and free Behance app for Windows Phone
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 10-23-2014, 06:50 PM
  4. Best Alternative Mail App??
    By dayoungtx in forum Windows Phone Apps
    Replies: 1
    Last Post: 10-23-2014, 02:13 PM
  5. Do you think 10 will get support for metro app default location changes?
    By ZackTheNever in forum Windows 10 Insider Preview
    Replies: 0
    Last Post: 10-23-2014, 01:45 PM
LINK TO POST COPIED TO CLIPBOARD