1. ML10's Avatar
    Did a hard reset, yet the fluidity isn't what I expected. Some problems I still get are

    -when I press the start button, it shows loading for a long time, and then returns to previous app.
    -Cortana, when holding search button, crashes after a long loading period.
    -Notification center lags.
    -Receiving the same SMS over and over again.
    -Tiles are sometimes blank or not present.

    I know it's a 521, and performance won't be great, but some of these issues nag at me.

    Thanks for any help.
    03-02-2015 07:15 PM
  2. faith3935's Avatar
    Did a hard reset, yet the fluidity isn't what I expected. Some problems I still get are

    -when I press the start button, it shows loading for a long time, and then returns to previous app.
    -Cortana, when holding search button, crashes after a long loading period.
    -Notification center lags.
    -Receiving the same SMS over and over again.
    -Tiles are sometimes blank or not present.

    I know it's a 521, and performance won't be great, but some of these issues nag at me.

    Thanks for any help.
    May be a time for a upgrade? Depending what your budget is you can look into buying another Lumia or wait for the Lumia 640 get released by T-Mobile.
    03-02-2015 07:19 PM
  3. ML10's Avatar
    May be a time for a upgrade? Depending what your budget is you can look into buying another Lumia or wait for the Lumia 640 get released by T-Mobile.
    I wish I could trust me. But that's up to my parents. I'm just a kid.
    03-02-2015 07:21 PM
  4. heickelrrx's Avatar
    Did a hard reset, yet the fluidity isn't what I expected. Some problems I still get are

    -when I press the start button, it shows loading for a long time, and then returns to previous app.
    -Cortana, when holding search button, crashes after a long loading period.
    -Notification center lags.
    -Receiving the same SMS over and over again.
    -Tiles are sometimes blank or not present.

    I know it's a 521, and performance won't be great, but some of these issues nag at me.

    Thanks for any help.
    Try black background. Then use few tiles than more tiles in appearance setting.

    Don't use too much tiles in total. Open the battery saver and check which apps that can run in background. Disable all non essential apps that rub in background

    Oh yeah clear all messages on messenger client if they already too much
    ML10 likes this.
    03-02-2015 07:23 PM
  5. ML10's Avatar
    Try black background. Then use few tiles than more tiles in appearance setting.

    Don't use too much tiles in total. Open the battery saver and check which apps that can run in background. Disable all non essential apps that rub in background

    Oh yeah clear all messages on messenger client if they already too much
    Ok did that. Helped the lagging on start screen. Anything else?
    03-02-2015 07:28 PM

Similar Threads

  1. Replies: 3
    Last Post: 03-03-2015, 12:21 AM
  2. Why do I have weird lines on my screen?
    By ImAfluffballKirby in forum Ask a Question
    Replies: 4
    Last Post: 03-02-2015, 10:19 PM
  3. Come on 640XL!
    By zhris in forum Carrier Discussion Lounge
    Replies: 4
    Last Post: 03-02-2015, 09:35 PM
  4. My Samsung ATIV S - 8.1 diagnostic tool Ody81, how do I force 3g?
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 03-02-2015, 04:54 PM
  5. How do I open my phone?
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 03-02-2015, 04:33 PM
LINK TO POST COPIED TO CLIPBOARD