1. Windows Central Question's Avatar
    I got the 'pop-up' of the Install the 8.1 Windows update on my Nokia Lumia 625. Once I clicked install, it said it would take 15-30 mins. It went to the screen with the gears turning, it slowly updating. But after a while, it just shut off. It has been over 4 hours now, everytime I go to turn on my phone, it goes to the gear screen (for about 15 seconds) and then shuts off, once again. Can you please tell me what I can do to fix this? My phone had a lot of important data, picture, etc. I would rather not get another one..
    03-07-2015 11:11 PM
  2. Xsled's Avatar
    Do you have it plugged in to the charger?
    03-07-2015 11:17 PM
  3. Deadly2Lumia's Avatar
    Big updates usually require charger to be in the phone
    friendslemonade likes this.
    03-07-2015 11:24 PM
  4. friendslemonade's Avatar
    It is currently now on the charger ( my charger doesn't work the best). Also I am who made this Question (I made account)
    03-07-2015 11:27 PM
  5. friendslemonade's Avatar
    Do you have it plugged in to the charger?
    Do I leave it in the charger for 15-30 mins?
    03-07-2015 11:45 PM
  6. RumoredNow's Avatar
    Just leave it plugged in... If the phone does not boot when plugged in either the battery is flat and you need to leave it plugged in till it boots (a couple hours)... Or your charger/cable is bad... Do you have a known to be good cable you can use and a PC USB port?
    03-08-2015 10:31 AM

Similar Threads

  1. My Lumia 930 is dead
    By maverick786us in forum Nokia Lumia 930
    Replies: 17
    Last Post: 03-24-2015, 05:14 PM
  2. Replies: 3
    Last Post: 03-09-2015, 09:02 PM
  3. Replies: 3
    Last Post: 03-07-2015, 11:53 PM
  4. Why has my screen gone black? [Lumia 830]
    By Windows Central Question in forum Ask a Question
    Replies: 4
    Last Post: 03-07-2015, 11:28 PM
  5. Replies: 1
    Last Post: 03-07-2015, 11:09 PM
LINK TO POST COPIED TO CLIPBOARD