1. Windows Central Question's Avatar
    I am using L1520 W8.1 GDR2 updated via Windows Insider.
    I'm having problems opening Photos from ANY app (like trying to upload a pic on FB, upload a photo on 6tag, or share a pic on Skype, Viber etc). Every time I choose the option to select from my Photos, the Photos app opens and it shows zero pic PLUS like a 3 second hiccup/loading time then the Photo app quit back to the app I have been in before.
    Occasionally, it succeeds in opening my phone Photos (like 1 out of 10 times) and let me choose a pic for once. So what I have been doing is attempting to do it over and over until the Photos app show the pics. But sometimes it doesn't let me do that, like from the KIK app for example, click Share Photos the second time after the first quit, the whole KIK crash and I had to open it again. :(
    Also note that I have no issue at all open the Photos app itself from start or menu. I don't know why or how it happens and how to fix it. Does anybody experience a similar problem? If so, please help me out!

    PS: I noticed, I think it has linking apps problem, as I had similar issue connecting to Facebook account from various games like candy crush too
    07-06-2015 02:54 AM
  2. RumoredNow's Avatar
    I am using L1520 W8.1 GDR2 updated via Windows Insider.
    Most likely this is the root cause of your issues. Insider was never meant as a vehicle to get Update 2 and remain there.

    Have you tried opening Photos > select > checking one or more pics > tap share > then into FB, kik, whatever???

    You might want to restore your phone to official: How can I recover/reset/restore my phone software? - Microsoft - USA
    07-06-2015 09:51 AM
  3. rponting's Avatar
    I have exactly the same problem on my newly purchased lumia 640xl running denim.... I am not sure what's causing the problem? Any help?
    07-24-2015 12:46 PM
  4. lucazzo's Avatar
    Having this issue on a 735 after updating to GDR2.

    All photos are stored to SD card.

    Two days ago I formatted SD card, and then copied photos to it from backup. Everything worked perfectly. Today, it stopped working again. HELP!
    08-11-2015 02:59 PM
  5. razukual's Avatar
    I'm having the same problem, currently running 8.1, it keep sending me back to the app. Photos won't even open.
    08-23-2015 02:57 PM

Similar Threads

  1. Replies: 2
    Last Post: 07-08-2015, 04:05 PM
  2. Universal mail app and gmail, no go?
    By vodda in forum Windows 10 Insider Preview
    Replies: 1
    Last Post: 07-07-2015, 08:41 AM
  3. How do I get to the latest build of Windows 10 (I'm stuck on 10130)?
    By Windows Central Question in forum Windows 10
    Replies: 2
    Last Post: 07-06-2015, 01:58 PM
  4. On a Nokia Lumia 530 how do you fix it from thinking too much?
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 07-06-2015, 03:37 AM
  5. Unable to ON the Wifi and Mobile Data in Lumia 520 after instaling Windows 10 from Windows insider
    By Sri Rama Reddy Satti in forum Windows 10 Mobile Insider Preview
    Replies: 2
    Last Post: 07-06-2015, 02:22 AM
LINK TO POST COPIED TO CLIPBOARD